2
$\begingroup$

Currently have 2.79 on windows 10. Previously also had 2.80 but got rid of it to download a later build. Now WHEN I download it I cannot launch it successfully:

I proceed as normal to open it... ie click on blender.exe to launch it.But at this point it fails saying. " Code execution cannot proceed because the following cannot be found (though I can see them all there).. avcodec-58.dll, python 37, SDL2, avformat-58.

Though I already have 2.79 working well - I downloaded it again (to see if the problem was just 2.80 and when I came to launch it got... code execution cannot proceed because following not found: python 37.dll, libsndfile-1, open Al32, SDL2.dll

Any suggestions on how I can proceed to rectify this would be greatly appreciated.

$\endgroup$
4
  • 3
    $\begingroup$ It is unclear what you are asking. Please try to reform the question in a clear and consistent manner only using terminology that you are sure about. If you cannot download it and it is not downloaded, what are you trying to run when you get the error message? What is a clean boot?.. If you want to run 2.80, you need to download it. It comes in a .zip file that you need to extract somewhere and only then you can run Blender from the folder that you extract from the downloaded zip archive file. $\endgroup$ Commented May 3, 2019 at 13:39
  • $\begingroup$ Thanks Martin Z & cegaton for directing me to better clarity $\endgroup$
    – Gavia
    Commented May 3, 2019 at 15:11
  • $\begingroup$ try uninstalling the program using the preferences in the operating system (or manually delete the contents of c:\Program Files\Blender Foundation, then manually delete all contents from c:\\users*your_user_name*\AppData\Roaming\Blender Foundation\Blender and re-install blender. $\endgroup$
    – user1853
    Commented May 3, 2019 at 15:55
  • $\begingroup$ I followed your advice, cegaton and deleted anything related to 2.80 in the c:\\users etc....but am afraid to take 2.79 out in case I cannot get it in and working again. There was a bunch of straggling 2.80 data that I manually deleted but new efforts at launching yielded the same result as before. Thanks for the suggestions. Guess I will uninstall all Blender soon but need 2.79 that is working right now. Thanks cegaton for your time and suggestion! $\endgroup$
    – Gavia
    Commented May 3, 2019 at 18:16

1 Answer 1

1
$\begingroup$

I think what's going on here is that double clicking the zip file in the file browser doesn't actually extract the zip file contents, it just gives you a view of the zip file contents. That looks just like if you had extracted the zip file.

What you should do is:

  • Download the zip file
  • Right click it and do "Extract all"
  • After extraction is done, you should now be able to execute blender.exe from within the extracted folder.

One thing to look out for is that inside the not-extracted zip file, blender.exe will have a generic (non-Blender) icon.

After "Extract all", blender.exe will have the Blender icon.

The above instructions solved my problems when trying to run Blender 2.80 RC2 from a zip file on Windows.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .