0
$\begingroup$

I've made clothing for a character. I want the clothes as simple as possible. I use a Solidify modifier and a Subdivision modifier after it. There is one problem. I can't get the corners sharp. Edge creasing only works with at least 2 connected vertices.

Plane without any modifiers

This is an example. A plane without any active modifiers.

Plane with Solidify modifier

Now it has a solidify modifier

Plane with Solifify and Subdivision modifiers

And now it has Subdivision after Solidify. As you can see, the corner gets rounded or smoothed out. I don't want that. Also, I want to keep the Subdivision modfier BEHIND the Solidify modifier to make the cloth look more realistic.

Plane with Subdivion before Solidify

Or else it will look like this.

I tried creasing the edges... but it only creases the edges, not the corners. Solidified-Subdivied Plane with edge creasing

Also it defeats my purpose of having the Subdivision modfier BEHIND the Solidify modifier.

The Rim crease setting

Using the Rim Crease in the Solidifer modifier setting I found a way that almost brings me to my goal...

Rim crease

Rim crease negative byeffect

...but as you can see, it comes with a negative byeffect when the edge vertices are moved. You can definitely see the crease takes place to all edge vertices, making them look bad.

Are there other options I can get my corners sharp?

$\endgroup$
1
$\begingroup$

Have you tried using an angle-limited bevel modifier after the solidify? You can tweak the angle as appropriate, but that ought to dynamically add more geometry exactly where you need it to convince the subsurface that you want more defined corners and edges.

It has the advantage that it's dynamic and doesn't care about the shape of your objects - but the disadvantage that it DOES care about the angles involved, and it will most certainly add more geometry to the mesh - but then, the manual method of adding loopcuts also does that. You get to pick how and where though, which can help.

I had a play around and using the other limit modes on the bevel doesn't seem to help much, but if angle limited isn't working they are potential options also.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.