0
$\begingroup$

does doing this work the same way as of in the stable version of blender 2.79? And another thing is that the video i am wanting to add to a plain is 2 minutes and 44 seconds long is there a duration limit on putting a video on an object?

$\endgroup$
  • $\begingroup$ have you tried? $\endgroup$ – Sazerac Apr 29 at 4:33
3
$\begingroup$

How do i play a video through an object on blender 2.8? does doing this work the same way as of in the stable version of blender 2.79?

Yes. Import >Images as Planes.

You can also drag and drop as an active empty to bench it.

And another thing is that the video i am wanting to add to a plain is 2 minutes and 44 seconds long is there a duration limit on putting a video on an object?

To my knowledge, no. However, it seems to play slower with large files. my best experience has been when using Eevee. 3 minutes should play fine.

Blender's 2.8 latest build supports this feature. https://builder.blender.org/download/

Plays butter smooth on my PC.

Import images as planes is an add-on

To enable it, go to Edit -> Preferences -> Add-ons.

enter image description here

$\endgroup$
  • $\begingroup$ oh okay cool that makes sense now i didn't know there was an add on for that thanks for that ill give a go and see what happens. $\endgroup$ – AunRa636 Apr 29 at 5:36
  • $\begingroup$ If a movie file doesn't update the frames correctly in the viewer, you can put a driver in the Image/movie node's frame offset value. Type in #frame to the value window, it should turn purple. Then the frames will update when scrubbing the timeline. $\endgroup$ – 3pointedit Apr 29 at 7:31
  • $\begingroup$ @3pointedit how do you put a driver in the image/movie node's? this is my first time trying to do this i didn't really need to know how to do this until i started learning how to use the video sequencer which it kinda of does matter now because i wanna import my own videos i edit or make into my animations. $\endgroup$ – AunRa636 Apr 30 at 0:26
  • $\begingroup$ Make sure that the image as planes object is selected then opens Shader window, there you'll see a bunch of nodes. Find the movie texture node and at the bottom you'll see the Frame Offset value. In there type- #frame . The window will turn purple when you press enter. Then it should play back correctly when you change frames. This is just a work around for now, until Blender 2.8 textures get fixed up. $\endgroup$ – 3pointedit Apr 30 at 23:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.