0
$\begingroup$

my keyboard has two layouts - Latin (English) and Cyrillic (Russian). Currently, in Blender 2.8, keyboard shortcuts work only with English layout - at least, on a Mac and Linux. Is there any way to make them work with Cyrillic layout too?

(Because that constant layout switching is very inconvenient and slows the work down.)

Thanks!

$\endgroup$
  • $\begingroup$ I don't think you can, I cannot try it out but if you go into preferences and then to the tab with the shortcuts you could try to set your own shortcuts $\endgroup$ – DrachenSeele Apr 27 at 22:56
  • $\begingroup$ Tried that on Mac and Linux. When I try to assign any Cyrillic character for any shortcut, Blender displays the Latin character, assigned to this particular key. Apparently, Blender accepts only Latin characters as custom shortcuts. $\endgroup$ – a-tokarev Apr 29 at 11:42
0
$\begingroup$

If I can accidentally get it to work on my French keyboard (most confusing, btw), then you can get it to work for your computer. Just get the keyboard, and set the keyboard (usually under language preferences, bottom right for windows, idk for a mac) up for the language that you want, and the computer will use that keyboard for everything, you don't need to do anything in blender. That should do it. Also, idk if this is just a Windows thing, but if you press alt-shift, it switches languages, which is annoying if you accidentally press it, then all of your shortcuts are messed up.

$\endgroup$
  • $\begingroup$ Thanks, guys. I have once again re-checked how blender operates on dual-layout machines. My findings so far: $\endgroup$ – a-tokarev Apr 28 at 10:18
  • $\begingroup$ - on Windows 10 and Linux (elementary OS 5, Ubuntu-based) shortcuts in blender work perfectly on both layouts (EN/RU) ; - on macOS Mojave - only EN shortcuts work. When I switch to Russian layout, blender doesn't respond to shortcuts. So I guess, this issue is rather platform-specific, than blender-specific. If you know how to fix it on a Mac, let me know. $\endgroup$ – a-tokarev Apr 28 at 10:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.