2
$\begingroup$

I have a Normal Map problem: I've baked a high-poly sphere to a low-poly, but whatever I try there's always a bad shading on the surface of the low-poly in Rendered display, between the light and the shadow. It disappears if I unplug the Normal Map. What am I doing wrong? Is it inevitable? Am I missing something? Thanks in advance.

Edit: Solved by Serge, it looks like it's the terminator issue, fixed with a bigger light size. Answer also given here by IkariShinji, and as Leander pointed out, here by Crazycourier.

file:

enter image description here

$\endgroup$
  • 5
    $\begingroup$ Looks like terminator problem $\endgroup$ – Serge L Apr 27 at 16:09
  • $\begingroup$ wow you're right and it seems like the solution is to increase a bit the light size, thanks a lot, please give an answer so that it can be considered as solved. It took me the day to understand :p $\endgroup$ – moonboots Apr 27 at 16:34
  • 4
    $\begingroup$ Possible duplicate of Some areas of the mesh are dark. Related and related (autosmooth). $\endgroup$ – Leander Apr 27 at 17:27
  • $\begingroup$ thanks for your suggestions, Crazycourier answers correctly in your second link when he talks about light setups, in my case the solution won't be to Smooth shading (it's already smoothed), nor increase the topology (it would ask a very high level of subdivision and anyway it would make no sense in that case, Normal Map is used to avoid high-topology), nor Auto-smooth (doesn't work), but increase the light size. $\endgroup$ – moonboots Apr 27 at 18:56
  • $\begingroup$ blender.stackexchange.com/questions/27982/… $\endgroup$ – Duarte Farrajota Ramos Apr 27 at 23:27
3
$\begingroup$

Terminator issue hasn't got a proper solution for Cycles yet. Increasing Lamp's size makes penumbra bigger and issue becomes less visible.

Size setting is here:

enter image description here

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.