4
$\begingroup$

I have a blend file with multiple objects positioned side by side. This file is intended to be used as a library and I don't want to separate them in different files because they are simple variations of the same kind of object. I also created groups for every object (some of them are composed of other objects). This is something like this:

enter image description here

When I link an object from the previous file that is positioned at origin, it's created at the cursor position on the new file and I can rotate it around their own axis like this

enter image description here

But if I link another object from the previous file that is not at the origin on that file, their axis is not aligned with the object

enter image description here

How can I link it in a way that the linked object has the axis aligned with the object?

$\endgroup$
4
$\begingroup$

If you link an object, all properties of the object are in the file from wich you linked the object.(inclusive the position)
If you want to keep your object movable, you can link the mesh(not the Mesh Object) of the object. Then create a new mesh-object, go to the object-Settings() of the object in the properties window and change the Mesh() to the linked Mesh.

$\endgroup$
  • 1
    $\begingroup$ Another option is to use the Make Local button on the linked object (in the object pane of the Properties view next to the object name) to transform it into a local Object datablock pointing at the foreign mesh datablock. $\endgroup$ – Mutant Bob Jun 18 '15 at 20:57
4
$\begingroup$
  • Group Ctrl+G the object by itself.
  • Set the cursor to the origin of the object with Space + Snap Cursor to Active.
  • Go to the object properties panel and choose Set offset from cursor under the group options drop down arrow. Set offset from cursor
  • Finally go to your other file and link the group, not the object. Linked object
$\endgroup$
1
$\begingroup$

It is possible that the objects in the source library .blend file have their mesh origins "outside" the mesh geometry. If this is the case, you might want to use shift-ctrl-alt-c to set Origin to Geometry (you will have to do this while editing the source .blend). Or if you want better control over the new origin, set the 3D cursor first, and then use the same menu to set Origin to 3D Cursor.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.