0
$\begingroup$

I want to pour cubes which are in the image. However when I animate blender p plane passing through to the cubes. How can I solve this problem? I just want to pour cubes and observe falling of cubes when I animate.Can you Help me? Thank you...enter image description here

$\endgroup$
  • $\begingroup$ Have you applied a Collision Modifier to the plane? $\endgroup$ – Ben Apr 25 at 12:53
  • $\begingroup$ No , Can you help me? $\endgroup$ – Nasır Esmerer Apr 25 at 14:10
  • 1
    $\begingroup$ Ok so I just realized that you were using animation nodes. Would be easier to actually mention it in your problem description to save time trying to understand the problem. Do you have the same issue when you are not using animation nodes? $\endgroup$ – Kiskit Apr 26 at 7:57
0
$\begingroup$

[Final Edit now I think I understand the problem better]

OK, so I have the same behavior as you if I use your AN setup. Blender expects the passive to not be moving, or you to be explicit about it if it's moving.

So my solution:

Select cube, go to physics, add rigid body, select type active. Select plane, go to physics, add rigid body, select type passive. Under settings, tick Animated. Play animation.

It should work.

enter image description here

$\endgroup$
  • $\begingroup$ I tried but I cant solve problem? $\endgroup$ – Nasır Esmerer Apr 25 at 14:11
  • $\begingroup$ Are you sure your plane is passive? I think it should be surrounded by green when selected, not yellow. $\endgroup$ – Kiskit Apr 26 at 5:06
  • 1
    $\begingroup$ If you solved the problem thanks to an answer from another user, please mark it as answer. $\endgroup$ – Kiskit Apr 30 at 11:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.