I am trying to create a human model. The model turned out to be pretty "high poly". It is rigged with the automatic Pitchypoy rig that blender offers and everything worked fine (I think).

I reached a point where I wanted to make eye lashes. I tried making the entire body (the main mesh which is high poly) the Emitter and have the hairs emitted from the Faces and even though I have a decent rig (1070ti, 1800x, 32gb 3k ram) it made the program Insufferably laggy.

Following some tips from the internet I've made copies of each "Strip of Faces" that I want to emit hair. They are 4 separate strips with 100 hairs emitting from each. All named and the particle systems too. This eased the load on the system considerably but then I tried to do some posing and encountered the following issue:

When I deform the mesh, by moving the control bones of the Pitchipoy rig, the EMITTERs deform just fine (and the body mesh too) but the hair detaches from the Emitter and floats in the same fixed position where the emitter used to rest before the deformation. When rendered via Cycles (In Evee it looks fine) the lashes float a bit above the place where the Emitter is.

What I tried:

  • Putting the Armature Modifier at the top of the mod list and the Particle Mod at the bottom.
  • Particles -> Emission -> Source -> "Use Modifier Stack" is ticked ON.
  • Parenting: I think I've tried all the types of parenting. The Emitter to the Rig Bones, to the Body Mesh, to the Control Bones. With and without deform ticked...

Googling the hell out of this and seeing how solutions that worked for others ^ never helped me with (seemingly?) the same issue.

The setup: PC specs listed below though I doubt they matter.

  • Windows 10
  • Blender 2.8

The guess: I probably did not tick something somewhere that people find so very obvious they don't think that someone can miss that so they simply do not state it in the (many) answers I've read.

I need to parent the emitter to the particles it emits (?)... Somehow. Is this a Blender 2.8 bug?

In the attached SS:

The Orange outline: Particle Emitter (deformed).

The mesh: Deformed.

The Control bones: Moved.

The Particles AKA Eyelashes: Remaining where the Emitters used to be.

particle settings

Modifier order:

modifier settings

  • $\begingroup$ Could be because of different settings for view and render in the subsurface modifier. $\endgroup$ – Coffeehouse Apr 25 at 13:38
  • $\begingroup$ @Coffeehouse I love you Sir/Madam! You are a gentleman and a scholar! Who could have thought... I have no idea Why it causes this issue but making them equal immediately solved everything. IF ANYONE HAS THE SAME ISSUE READ THE 1ST COMMENT BY COFFEEHOUSE !!! $\endgroup$ – user73376 Apr 25 at 14:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.