1
$\begingroup$

I previously had Blender installed through the windows store (which worked ok), but I uninstalled it, intending to get the Steam version and/or the 2.8 beta. I tried both, but when I open either one it just shows a terminal window, then a blank white screen. I also tried the current (2.75b) version from the Blender website, which had the same problem.

My computer is a 64 bit windows 10 laptop with an NVIDIA NVS 4200M GPU (I think).

Can anyone help me find out why this is happening?

$\endgroup$
4
  • 2
    $\begingroup$ Never use the Steam version. It causes more problems than it solves. Try Blender 2.79 instead, but use the zipped version and extract it to your desktop. $\endgroup$ – metaphor_set Apr 24 '19 at 23:44
  • $\begingroup$ I tried it with the zip version, that doesn't work either. It does the same thing as the others. $\endgroup$ – Taliesin River Apr 25 '19 at 1:48
  • 1
    $\begingroup$ run it from a command prompt and edit your question with any error messages. $\endgroup$ – rob Apr 25 '19 at 12:56
  • $\begingroup$ I just updated my graphics card driver manually and it worked for me. $\endgroup$ – neo Jul 17 '20 at 21:01
1
$\begingroup$

The problem has been solved. It turns out my GPU needed a driver, but it had to be downloaded manually instead of just clicking "update driver".

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.