1
$\begingroup$

Using Blender 2.8 Cycles with Denoising and Caustics Turned-Off

I have two questions here.

  1. I’m not sure why the world background is not WHITE when I’ve already set it to FFFFFF in hex value.

  2. The glass panel of my model appears to have icing/frosting effect. I cannot get the CLEAR GLASS with REFLECTION on it.

What’s the correct way of doing it?

enter image description here

Thank you :)

$\endgroup$
2
  • $\begingroup$ Have you been using the denoiser? $\endgroup$
    – Leander
    Apr 24, 2019 at 15:41
  • $\begingroup$ Which Blender Version and Render Engine are you using? If you want a #ffffff BG I'd suggest to either render with transparent Background & composite with white BG after rendering. Or you could use a backdrop like shown here with proper studio lighting. Glass shader: Did you try to mix with a white Transparent or Refraction Shader instead of black Translucent? In Render settings you could also try to turn off Caustics under Light Paths (in Cycles :-)) You can also upload your file. $\endgroup$
    – ho.s
    Apr 24, 2019 at 16:15

2 Answers 2

1
$\begingroup$

First forget about thinking of color as Hex values. That is not how blender works. The same color will change depending of the amount of light that hits the surface of objects. Also the final value will depend as well on the kind of color transform chosen in the color management settings.

Let's start by asking what is "white"?

"White" is not a color, it is just the limit of what the display can deal with, in other words it is when the data has reached the top of the scale (from 0.0 or 100%) in all three channels. Most likely you need to increase the intensity of the light sources to reach that value.

Read:

Make texture visible in sunlight

and

Render with a wider dynamic range in cycles to produce photorealistic looking images

and

How do I stop my white background from becoming grey due to lighting?


As for the reflections on the glass, well, glass is both transparent and reflective, so you will have to control the elements that get reflected on it. If you don't have any reflections then the surface will no longer look like glass and the viewer will think that there is nothing there.

Read:

How to turn off reflections on glass

$\endgroup$
0
$\begingroup$

The Background is not total white as its brightness is not high enough but probably set to 1. You can try a node setup similar like this, two background nodes, one set to the background color you want, the other to how bright it should be. Connect them to mix shader. Then use a light path as the mix factor and plug IsCameraRay in the factor (you might need to play around a bit to find the correct one). This should make the background a different color without changing the lighting.

The frosting effect is odd but might be due to the nodes that you are using, I would suggest you to try a Principled shader node with transmission set to 1 and roughness reduced. Might solve the issue.

Is the plane smooth shaded? If yes that could also have some issues.

$\endgroup$
2
  • $\begingroup$ thank you guys for the feedback :) I realized the frosting was caused by Denoising, but i need that because fireflies will show up if turned off :) Figured out the Glass Shader as well, GLASS BSDF that's it. Thank you again $\endgroup$
    – Zamboolah
    Apr 26, 2019 at 11:41
  • $\begingroup$ To reduce fireflys you can try to use branched path tracing instead of normal path tracing. Increase the gloss clipping value or try a different glass setup. You can use the transparency light path trick. $\endgroup$ Apr 26, 2019 at 12:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .