1
$\begingroup$

I am trying to get a box to float into the air, fly in a direction and then midair activate physics so that it flies off and falls to the ground without me having to animate that. I tried keyframing the "animate" toggle so that it turns off, but when I do this, the box jumps back to its starting position, instead of continuing from where the animation left off. How do I enable physics mid-animation?enter image description here

$\endgroup$
3
  • $\begingroup$ Can you make sure that your object is an active rigid body and can you add a screenshot of your rigid body settings? Also have you tried baking the animation or are you only playing it back. $\endgroup$
    – Leander
    Apr 24 '19 at 8:14
  • $\begingroup$ Yes it is an active rigid body, no I'm just playing it back. What will baking the animation do? Would I do that before or after I keyframe the "animated" toggle? I've added a picture of my rigid body settings for the cube. Thank you! $\endgroup$
    – user73334
    Apr 24 '19 at 17:16
  • $\begingroup$ You might have an invalid cache. Try starting and cancelling a grab operation on the rigid body to reset the cache, then try again. If not, save and load and check behavior; if still a problem, link the file. $\endgroup$
    – Nathan
    Sep 30 '20 at 22:04
0
$\begingroup$

You need to change the simulation Start and End frames under Scene Properties > Rigid Body World > Cache.

[1

$\endgroup$
-1
$\begingroup$

At frame 0 put your object at its beginning location in the scene, press i > LocRotScale, enable the Animated option in the Physics panel and press i to keyframe it. At frame 10, move your object wherever you want, press i > LocRotScale, disable the Animated option in the Physics panel, press i to keyframe it.

$\endgroup$
3
  • $\begingroup$ Thank you, I'm doing this, but disabling "animation" under the rigid body settings causes the object to return to its starting point. Any idea why that might be happening? When I make a new simple animation, it seems to work how you have described, but when I try to keyframe the "animation" toggle on top of my existing animation for the cube, it jumps back to its starting position instead of falling from the sky. $\endgroup$
    – user73334
    Apr 24 '19 at 17:51
  • $\begingroup$ I don't think this answer describes what the OP wants. $\endgroup$
    – clankill3r
    Mar 19 at 21:37
  • $\begingroup$ @clankill3r, maybe I've misunderstood the initial question, maybe explain or give your own answer? $\endgroup$
    – moonboots
    Mar 20 at 3:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.