6
$\begingroup$

Can I use a video to texture a plane so I can use it as a reference for animating? It is important that I can view the texture without rendering the scene.

Edit: After loading an image as empty, I can't access the controls to Match Movie Length or Auto Refresh enter image description hereenter image description here!]1

$\endgroup$
6
  • 2
    $\begingroup$ Which render engine, cycles or internal $\endgroup$ Jul 9, 2014 at 21:41
  • 1
    $\begingroup$ @PandaAB It seems to me that the MOV file in question is encoded with codec that blender (or the operating system) cannot deal with. Quicktime files can be compressed on a wide variety of formats and still be a MOV file, in other words: quicktime is just a wrapper. Blender cannot decode all flavors. It is also possible that the version of quiktime in your operating system is preventing you to use that file. In any case, try converting it into an image sequence. All the answers in this page still apply for image sequences. $\endgroup$
    – user1853
    Jul 15, 2014 at 6:26
  • $\begingroup$ I am using both render engines but is there a specific one i should be using. $\endgroup$
    – Panda AB
    Jul 15, 2014 at 23:10
  • $\begingroup$ I have tried many different files and it is not working so should I have the newest version or what? $\endgroup$
    – Panda AB
    Jul 15, 2014 at 23:11
  • $\begingroup$ Hey thanks guys for the help but i figured it out and all i had to do was download the newest version. It is kinda weird because i had the 2.68 version instead of the 2.71 version but yet there was that much difference. Thanks again. $\endgroup$
    – Panda AB
    Jul 15, 2014 at 23:36

4 Answers 4

14
$\begingroup$

A different approach involves not using a plane at all but an empty as an image:

enter image description here

Select the image in the properties->Empty->Display tab

enter image description here

Click on match movie length and enable Auto Refresh You should see the number change in the Frames box on the left.

enter image description here

You'll get your image (or video) in an empty. The advantage of this method is that your image will be visible even in when the 3D viewport shading is set to wireframe or bounding box. Note that empties will not be rendered on the final render... enter image description here

$\endgroup$
8
  • $\begingroup$ I did what you said but every thing under display doesn't show. $\endgroup$
    – Panda AB
    Jul 14, 2014 at 23:54
  • $\begingroup$ The options will be available once you have chosen an image (or video) where it says Open. $\endgroup$
    – user1853
    Jul 15, 2014 at 0:04
  • $\begingroup$ It worked but when i scroll down the timeline the video on the plane doesn't play. And Auto refresh is on. $\endgroup$
    – Panda AB
    Jul 15, 2014 at 0:31
  • $\begingroup$ Did you click on Match movie length? $\endgroup$
    – user1853
    Jul 15, 2014 at 0:36
  • $\begingroup$ @PandaAB what is the format of your video file? $\endgroup$
    – user1853
    Jul 15, 2014 at 0:42
5
$\begingroup$

Tha lazy way to do this:

(Works for Cycles and Blender Render)

Press CtrlAltU to open the User Preferences and press on the Addons Tab.

Enable the "Import Images as Planes" addonenter image description here

In the 3D view press ShiftA and find Mesh->Images As Planes

enter image description here

Select the video you need. (Note that there are some options on the left for the texturing of the plane). enter image description here

A plane will be created with the proportions of the imported video, UV unwrapped and already textured with the chosen image.

enter image description here

All that is left to do is enable Auto Refresh on the texture nodes so the video updates as you scroll down the time line.

enter image description here

NOTE: The texture on the Plane will be visible only when the shading in the 3D viewport is set to Textured, Material and Rendered.

enter image description here

$\endgroup$
4
  • $\begingroup$ I did this way but when i import the video it doesn't show on the plane. $\endgroup$
    – Panda AB
    Jul 14, 2014 at 23:55
  • $\begingroup$ Make sure the viewport shading is on Textured or Rendered. $\endgroup$
    – user1853
    Jul 15, 2014 at 0:25
  • $\begingroup$ It worked but when i scroll down the timeline the video on the plane doesn't play. And Auto refresh is on. $\endgroup$
    – Panda AB
    Jul 15, 2014 at 0:26
  • $\begingroup$ @PandaAB this is an bug on cycles, have you ever got it working? $\endgroup$ Oct 4, 2017 at 11:51
3
$\begingroup$

Blender Internal

  1. Unwrap your plane
  2. add an image texture.
  3. Change the view mode to texturedenter image description here
  4. Hit N to open the tool bar, and under shading, change the type to GLSL enter image description here
  5. In the texture properties, hit the Match Movie Length button.
  6. Check auto refresh.
  7. Set the Mapping to UV, and select your UV map. Here is a picture of the settings:

enter image description here

$\endgroup$
3
$\begingroup$

Cycles

In cycles you'll have to put the video into the material nodes of your plane with an Image texture node.

  1. Add your plane

  2. UV Unwrap it (U)

  3. Create a new material and add a texture node. Click Open and select your video file.

  4. Enable Auto refresh.

  5. Switch to textured view and ensure the image texture node is active (last selected).

$\endgroup$
3
  • 2
    $\begingroup$ You can also use a video file as texture, no need to convert to image sequence. $\endgroup$
    – user1853
    Jul 9, 2014 at 23:40
  • $\begingroup$ @cegaton Wow, never knew you could do that. Thanks :) $\endgroup$
    – gandalf3
    Jul 9, 2014 at 23:56
  • $\begingroup$ Depending on the codec used on the video file, you might still get better performance using Image Sequences though. $\endgroup$
    – user1853
    Jul 9, 2014 at 23:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .