27
$\begingroup$

I have recently started using blender and one of the models I'm working on has dark shadows along edges. I started this model from scratch. I can't remember them being there when I first started the model, but I had trouble joining areas together and think I've pressed something I shouldn't have. However, there are so many options I'm not sure what I did.

Here is an image of what I mean
image showing shadow along edges

The one on the left has the shadow. As a test I started a new model, which is on the right in the image, and as you can see it doesn't have any shadows.

Also, occluded vertices partially show through the model. Occlusion doesn't work properly.
Extreme example

In orthogonal view small darkened triangles appear along the the edges. ortho clipping issue

I don't really want to start the model again from scratch so any ideas on how to remove this shadow would be great. Thanks.

$\endgroup$
1

3 Answers 3

20
$\begingroup$

If you changed the Clip Start value, this can exaggerate the effect in perspective mode. Find the clip settings in the right hand properties shelf, (The N panel), under the View tab.

n panel clip settings

$\endgroup$
5
  • $\begingroup$ Even if the user didn't change those, it can still be seen when zooming in really close to get precise detail $\endgroup$
    – Greg Zaal
    Commented Jun 26, 2013 at 11:16
  • $\begingroup$ mostly in perspective mode, right? $\endgroup$
    – zeffii
    Commented Jun 26, 2013 at 11:18
  • $\begingroup$ Clip start sorted, was on 0.010. In new models it is 0.100. Thanks very much. No idea how I managed to change that as that window does not look familiar at all. $\endgroup$
    – Ray
    Commented Jun 26, 2013 at 12:55
  • 2
    $\begingroup$ Also happens in Ortho, not exactly the same, perhaps worse: i.imgur.com/NV7OsJ2.jpg $\endgroup$
    – Greg Zaal
    Commented Jun 26, 2013 at 13:05
  • $\begingroup$ @Ray, please would you change your accepted answer to the answer provided by ideasman42, it provides a more complete answer. $\endgroup$
    – zeffii
    Commented Jun 27, 2013 at 17:44
33
$\begingroup$

The issue you are calling "shadow along edges" is more generally known as z-fighting (if you want to search for more info on the topic).

In our manual we document this problem:

A large clipping range will allow you to see both near and far objects, but reduces the depth precision.

To resolve, in the view settings you need to reduce clipping range.

  • set the Clip Start as high as you can before near geometry disappears.
  • set the Clip End as low as you can before far geometry disappears.

The Camera has its own start/end settings so you may want to adjust that too.

Note that typically you won't need to tweak this value often, it just needs to match the scene scale you use

A range between 0.1 -> 100.0 is fine if more model has dimensions of ~0.5 -> ~50 blender-units.

Note that some graphics cards cards suffer from this problem more than others because they use a lower bit-depth for their z-buffer.

$\endgroup$
1
  • 2
    $\begingroup$ The only time I find myself modifying the clip-start value is when I'm working at silly zoom levels, close-up at some tiny element of geometry. Lowering the clip-start value avoids the clipping from happening too soon. $\endgroup$
    – zeffii
    Commented Jun 27, 2013 at 21:21
1
$\begingroup$

I had the same issue and found this thread. I followed the instructions, but it still would not work.

I did find that going into my User Preferences and choosing a different preset remedied the issue for me. I saved my work, quit Blender, re-opened, and switched back to the theme I'd previously used and the issue remained solved.

I encountered this issue again and my fix mentioned above helped nothing. I did, however, solve it by opening the properties panel (N), making my way down to the Mesh Display twirldown and unchecking the box for Faces underneath the Overlays area.

-- The Mesh Display twirldown appears in Edit mode, but not in Object Mode.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .