2
$\begingroup$

I wanted to use the "Randomize Transform" tool as described here

Or in the first half of that video.

Following the video, after seperation of each individual cube into single objects, when I want to use the tool, everything is greyed out, like in the attached screenshot.

Randomized Transform greyed out

What am I doing wrong here?

$\endgroup$
  • 2
    $\begingroup$ That's very strange.. It works fine for me. Is it possible you could upload your .blend? $\endgroup$ – gandalf3 Jul 7 '14 at 19:51
  • $\begingroup$ It also works for me. I tried to get the greyed out dialogue that you describe by activating the tool with everything still as one piece and also by separating everything then activating the tool with nothing selected by it still activates properly in both cases. $\endgroup$ – MarcClintDion Jul 8 '14 at 5:31
  • $\begingroup$ I will upload the blend file shortly. And no, this is a completly different problem, Greg :) Edit: gandalf posted the solution. $\endgroup$ – skombijohn Jul 8 '14 at 10:47
  • $\begingroup$ Eh looks like exactly the same problem to me $\endgroup$ – Greg Zaal Jul 14 '14 at 14:25
3
$\begingroup$

Make sure Global Undo is enabled in CtrlAltU > User preferences > Editing > Undo:

enter image description here


That panel is called the redo panel, because when you change a setting on it, blender actually redoes the previous operator with the new settings.
If blender can't undo the previous operator first, running it again will add it's effect on top of the result of the previous operator (which is not the desired effect at all).

So this panel is disabled when undo is not available.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Why ever, but this is actually the solution here. Cannot see a relation between an undo setting and a function like this. $\endgroup$ – skombijohn Jul 8 '14 at 10:51
  • $\begingroup$ @skombijohn I added an explanation. $\endgroup$ – gandalf3 Jul 8 '14 at 17:57
0
$\begingroup$

Another option is using proportional edit.

Activate proportional editing O and set the falloff to random. While edit mode will effect vertices, when used in object mode it will move the entire object.

enter image description here

Select a cube in the centre and start moving it, You can use the mouse scroll wheel or PageUp and PageDown to change the size of influence. You will also find that as you change the radius of influence the positions will change, that works like choosing different seed values.

enter image description here

| improve this answer | |
$\endgroup$
  • 3
    $\begingroup$ While this is a good workaround, it's not a solution to the problem (which is not specific to the randomize transform tool, but rather a general UI issue) $\endgroup$ – Greg Zaal Jul 8 '14 at 8:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.