5
$\begingroup$

I am experiencing extreme lag when resizing (zooming in) the cycles node editor. I don't experience lag anywhere else in the blender UI. My specs: quad-core, 2.40 GHz 64-bit. No GPU. Does anyone have any solutions for this problem?

$\endgroup$
5
  • $\begingroup$ My laptop as the same problem $\endgroup$ Jul 6, 2014 at 14:21
  • $\begingroup$ I presume you are talking about the compositor. If you press N and look for the Performance Tab you can enable OpenCL to make things a bit faster. $\endgroup$
    – user1853
    Jul 6, 2014 at 17:09
  • $\begingroup$ @cegaton I think that option only makes compositing faster, not the interface (and you need an openCL capable device). It sounds like the OP is asking about material nodes. $\endgroup$
    – gandalf3
    Jul 6, 2014 at 17:46
  • $\begingroup$ I have the same problem, though only on computers that don't have a dedicated graphics card. On my work laptop (AMD Radeon HD 8650G graphics card), I don't experience any lag in the UI. $\endgroup$
    – Justin
    Jul 15, 2014 at 23:21
  • $\begingroup$ I find it interesting that all of us who have experienced this problem, do not have graphics cards. Starting to sound like a bug. $\endgroup$
    – David
    Oct 29, 2014 at 14:16

3 Answers 3

7
$\begingroup$

I think I figured this one out!

It's the rendering of the default interface FONT that causes the lag. It seems it has to do with the file size of the .ttf used by defualt in Blender (~5MB).

So in User Preferences->System->Interface Font, try switching to a .ttf font with a small file size. I used Lucida Sans at 53kb.

I'm not certain as to why the font's file size matters, but IT WORKS.

$\endgroup$
1
  • $\begingroup$ Note on this, I had to restart Blender for this to properly take effect. $\endgroup$ Dec 22, 2022 at 12:40
2
$\begingroup$

After reading ItsTheFont's answer, I played around with the settings and found that the Window Draw Method makes a big difference as well. It can be found at User Preferences > System > Window Draw Method. Setting it to Overlap was best for me.

My Interface Font setting is now set to OpenSans Regular.

A image showing where to find the Window Draw Method and Interface Font settings.
User Preferences

$\endgroup$
1
$\begingroup$

I have the same issue and find out that it happens only when Screencast Keys addon is enabled. When I deactivate it from the N- Properties Panel zoom in Shader Editor work fine.

$\endgroup$
1
  • $\begingroup$ This solution fixed the problem for me with Blender 3.4.1 when scrolling the mouse wheel would cause huge lag spikes when using Screencast Keys. $\endgroup$
    – stom
    Mar 10, 2023 at 19:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .