1
$\begingroup$

I'm currently confused as to what's going on with my animations. If I click the star icon to lock a certain animation and mute the others, each animation works correctly. If I have none starred, the default animation is always my walking animation, and the animations don't play correctly if I select them from the Action list; parts of the mesh deform. The character's right foot for the walk animation looks as though he's hobbling or trying to walk on tip-toes. I can have nothing selected in the NLA Editor or nothing from my Action list under the Dope Sheet, but it will always play my walking animation by default. I'm not sure why or how to change this. It almost seems like one or two of my animations have inherited keyframes from other animations with the way they deform. I even tried deleting every key frame from every animation so nothing shows for each action, and yet I've noticed the hands still move slightly. o_O

Why animations are the 'right' ones according to Blender? The ones I can star under the NLA Editor or the ones that are broken via the Action list of the Dope Editor. I'll upload my save file.

$\endgroup$
1
$\begingroup$

The action that will be played will be the priority one on the NLA, i.e. the one on top track, except:

  • 1: If you've selected a strip in the NLA and pressed tab to edit its action in the Dopesheet/Action Editor. To come back to the normal NLA running, press tab again on the NLA (or press the X button on the right of the action name in the Dopesheet/Action Editor).
  • 2: If you've loaded an animation in the Dopesheet/Action Editor mode from the dropdown menu. To come back to the normal NLA running, press the X button on the right of the action name.

But be careful: If the animation you've selected misses keyframes for some of its bones, these bones may be playing some inexplicable keyframes, actually coming from other NLA strips below your one or from previous animation. To prevent this to happen you can press the star icon of your track or mute the others. But the best thing to do is to keyframe your whole armature in Pose mode, at the beginning of each action, to make sure that no bone will inherit pose from another action, unless you have a good reason not to.

Also, about NLA strips: If you want the keyframes of an animation strip to continue to influence the armature even after the end of the strip length, choose the Hold option in the Extrapolation dropdown menu of the Properties panel of the NLA (activate with N > Animations > Active Strip.

About actions: Don't forget to press the F button on the right of the action name, in the Dopesheet/Action Editor mode. This way you're sure this action won't be deleted when you'll reopen your file, even if it's not used anywhere.

About your foot hobbling, it happens in the middle of your action, frame 20 when the left foot is forward. To fix it, go in Pose mode, select all the bones at frame 0 (or at least the leg bones), ctrlC, come to frame 20, where the pose is supposed to be inverted, select all your bones and press shiftctrlV, then i to keyframe the pose. It works.

$\endgroup$
  • $\begingroup$ Thanks for the info and the suggestion. :) How do you change the priority animation, such as from Walk to Idle? Is that even possible? I've also noticed that if I play the walk animation and then select the Idle animation either from the Action list or pressing tab on the strip, the idle becomes deformed and looks like some weird mech from a Metal Gear Solid game lol. $\endgroup$ – DustyShinigami Apr 23 at 11:18
  • $\begingroup$ I'm still really confused when setting up a new Action or strip. I'll click on the cross to remove the current one, create a new one and name it, go to the NLA Editor, add a keyframe for a bone or two, and click on the drop-down arrow to add the strip, but it still incorporates the walking animation to the new one, making it look deformed. :-\ $\endgroup$ – DustyShinigami Apr 23 at 11:55
  • $\begingroup$ to play a strip then another one you can put the second strip after the first one on the same track, or let the second one on his own track below, but in this case make sure that the first strip extrapolation is set to Nothing (in the N panel, on the right of the NLA editor > Animations tab > Active Strip > Extrapolation), otherwise the others strips below won't play. $\endgroup$ – moonboots Apr 23 at 12:37
  • $\begingroup$ Also, if you bring some modifications to your action, make sure that you've refreshed the strip length, in the N panel > Animations > Action Clip > Sync Length + click on Now button $\endgroup$ – moonboots Apr 23 at 12:39
  • $\begingroup$ oh and another thing you need to know: if there is no keyframe for some bones on your top strip, the keyframes for these bones of the strip below will be taken into account $\endgroup$ – moonboots Apr 23 at 13:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.