0
$\begingroup$

Im sure it's probably a render option I need to turn on or off but I have an animation where we see a crane moving a sign. As the sign comes closer to the camera, the crane disappears. I keyframed the material to be transparent and also keyframed the eye ball (viewport visibility). Most of the objects fade out but these black wireframes are left behind. When I switch to Render Viewport nothing is there but when I actually render, the wireframes are present. Any ideas? Rendered Viewport Actual Render

$\endgroup$
  • $\begingroup$ Which renderer are you using? (..And which button are you pushing to perform the render?) $\endgroup$ – Robin Betts Apr 22 at 20:34
  • $\begingroup$ @RobinBetts I am using Cycles. I press F12 to render but also rendered the entire sequence to .jpgs by pressing the Animation button and had the same issue either way. $\endgroup$ – frowest Apr 22 at 20:45
1
$\begingroup$

Not sure I completely understand, but if you want to hide items from the renderer you need to click on the little camera icon (hides in render), not the little eye icon (hides in viewport).

$\endgroup$
  • $\begingroup$ Thank you! Super noob here but appreciate your input. Any idea why my objects still have that black wire-frame like material appearing even though I set their material to be transparent BSDF? $\endgroup$ – frowest Apr 22 at 21:47
  • $\begingroup$ Afraid I'm not sure. Could be a number of things. If you are up for sharing, then upload your file to pasteall.org/blend and add the link here. That will give us the best chance of helping you. If not, then perhaps post a couple of screenshots showing your material settings (nodes and material properties panel). $\endgroup$ – edna Apr 23 at 3:21
  • $\begingroup$ I uploaded it here: pasteall.org/blend/index.php?id=51612 $\endgroup$ – frowest Apr 23 at 17:01
  • $\begingroup$ Ah ha! Your light is getting 'trapped' inside your transparent material. You don't have enough transparency ray bounces for the light to escape, so it renders as black. In Properties panel, go to Render / Light Paths and increase the Transparency number to about 60 and your crane will render as completely transparent. $\endgroup$ – edna Apr 25 at 3:50
  • $\begingroup$ Genius! Solved! $\endgroup$ – frowest Apr 25 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.