0
$\begingroup$

I am working on a math-art animation in which a complicated object is changing and growing in the center of the scene. I want to animate the camera to follow a log spiral path that I've used a mirror modifier on to create a closed path that spirals out then back towards the object.

I'm using ADD:Curve:Curve Spirals:Logarithmic, then a mirror modifier. That works: I get what appears to be a single closed curve (it selects and shows in object and edit mode as one curve). But when I set up the camera to track on this curve the camera tracks correctly to the point where the original spiral connects to its mirror image, ignores the mirrored part, and jumps back in to the beginning of the original unmodified curve.I did the modifier part before any of the camera tracking part.

I'd like to know how to fix this manually for now, though ultimately I will add this piece to my python script that does most of the work in this project.

I've added some screen shots in both object mode and edit mode. In object mode the whole thing selects as one object but going into edit mode only the original spiral is highlighted and I can't seem to affect the mirrored half. Going into the object's curve tab Geometry panel I noticed that setting the bevel depth to non-zero bevels the whole thing. Thought this might be a clue to someone, though it just adds to my confusion.

The mirrored spiral in Object Mode

The same thing in Edit Mode

Yet bevel treats the whole thing as one.

$\endgroup$
0
$\begingroup$

You will need to apply the modifier enter image description here

I'm not sure what the width will do, but I think you shouldn't have it unless you need it for some sort of visual for yourself.

$\endgroup$
  • $\begingroup$ Thanks for the suggestion avatar. I tried it but that undoes the already set camera tracking along the curve while looking at the origin. I tried to redo the tracking but discovered that when the curve becomes a mesh the parenting menu (Ctrl-P) won't offer the "follow path" option. However, I then tried converting that back into a curve (weirdly Alt-C wouldn't come up but the option was still in the Object menu of the 3D view). That worked, I redid the camera following curve and IT WORKS! I had read elsewhere that the Apply button is to be avoided if possible but in this case it was the key. $\endgroup$ – tomba Apr 23 at 2:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.