1
$\begingroup$

I imported a gltf model in Blender and it's way too big. If I convert the same model to .obj before, I can import it in Blender and set the Clamp-Size to 1.00 and the scaling is alright. Unfortunately, the gltf importer in Blender 2.8 doesn't have such an option.

I already tried selecting everything and scaling it down in the Transform tab to 0.01 (seems to be the lowest I can set it to) but it's still way too big (still so big that Blender is cutting the view in half because one end is "too far" away).

Is there any way to resize it? Im importing an ArchiCAD model which unfortunately doesn't give me any options on export.

Thanks

$\endgroup$
  • 1
    $\begingroup$ Once you've loaded a model into Blender it doesn't matter what the original file format was, scaling works the same with any mesh. Are you sure you can't scale the mesh less than 0.01? Can you share a .blend file? $\endgroup$ – Don McCurdy Apr 22 '19 at 5:29
0
$\begingroup$

As Don mentioned in a comment, you should be able to scale the object smaller in a variety of ways, regardless of import format. You can use the S key and drag the mouse towards the center, which can be repeated multiple times, or you can directly enter numbers (smaller than 0.01) on the Transform panel.

But before you do that, here's something else to consider:

If this is an architectural or other genuinely large model, scaling it down is likely the wrong solution. You want to configure Blender to be able to preview a larger volume of space.

Open the Numeric panel (if it's not already open, press N in the 3D panel), and look for the clip settings:

Clip Start and Clip End

The rules here are a little strange, but I'll try to explain. Roughly, you don't want the Clip End value to be more than about 10,000 to 100,000 times larger than the Clip Start value. The more digits you put between these two numbers, the more strain you're placing on something called the "depth buffer" which is how a 3D graphics card figures out which polygons are in front.

For example, if you set Start to 100m and End to 10000000m, you should be able to preview a very large model, cleanly. But if you only set the End value super large, and leave the Start value at its default, you may start to see flickering (Z-fighting) between some of the polygons, depending on how close they are to overlapping. The good news is, when you're viewing something that large, you don't typically need to get the camera to zoom in on the tiniest details, so the Clip Start can move further away from the camera.

So my advice is, start by adding zeros onto the back of the Clip End number, until the whole back of the model comes into range. Then, if you see problems, start adding zeros to the Clip Start value, one digit at a time, until the problems subside.

|improve this answer|||||
$\endgroup$
  • $\begingroup$ thanks, I didn't know that changing the clip values was the proper way to that! $\endgroup$ – tobias Apr 22 '19 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.