I have created an Collection Instance, when I try to move it, the origin(to snap at vertices or edges) is far away from the object, I want to set it.

enter image description here

In the image, the Collection Instance is selected, the cross is far away from the object and I can´t set it using "Set Origin to 3D Cursor"

What Am I missing?

  • $\begingroup$ Not the best solution, but in edit mode of objects, the origin point doesn't move. Can you try moving the collection group in edit mode? $\endgroup$
    – Mike
    Dec 29 '19 at 15:10
  • $\begingroup$ If you Right Click the collection and "Select Objects" it should allow you to do it then. But I'm not sure if this would solve your issue. $\endgroup$ Jan 9 '20 at 14:37

First Method : Set the origin in the base collection

To change the origin of a collection instance, you have to go to the object information panel, then the collections foldout and choose "set offset from cursor" with the drop-down popup on the right of the collection name.

enter image description here

Second Method : Set the origin in the collection instance

There is another way to do it as pointed out in the comments. Select the collection instance and type F3 to search for "Set Origin" and choose accordingly to your case. Alternatively go to Object>Set Origin.

Note that this will be a bit more work if your object's origin is not in the center of its geometry. You can still manually place your cursor and choose "Set Origin" "From Cursor".

enter image description here

  • $\begingroup$ WOW! I also want to add to this post ( since I had this issue come up again ) that the best way to do this I think is to just click on the instanced collection and set the origin point to geometry and then boom... finished :) $\endgroup$ Apr 9 '20 at 6:54
  • 1
    $\begingroup$ @CameronT0101 I did'nt realize you could do that ! Strangely the "Set Origin" option doesn"t come up when you right click with a collection instance selected, but you can still use the F3 search bar to get it or by the regular menu. I'll update my answer $\endgroup$
    – Gorgious
    Apr 9 '20 at 6:57
  • 1
    $\begingroup$ Yes, I did forget to mention that I have power snapping pies installed ( Master Xeon 1001 add - on ) so for me it came up and worked instantly. Anyways, this was a very happy mistake and I hope it helps others! $\endgroup$ Apr 9 '20 at 7:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.