1
$\begingroup$

When I render to OpenEXR (multilayer) in Blender 2.80 (Cycles) and then import it back into After Effects (2019) the image looks way too dark.

What it looks like in Blender 2.80:

blender render

What it looks like in After Effects:

AEX import

I've tried playing around with the color management settings in Blender but it doesn't seem to make a difference. I've tried opening the EXR in other applications like IrfanView and Photoshop but that doesn't work at all (either an error or a black image).

$\endgroup$
1
$\begingroup$

When you export as EXR you are creating an image that is in in a linear scale. In other words you are bypassing the transformations set by the color management in blender. You would need to interpret the exr image in after effects so they it understands that is dealing with linear data.

As an alternative, do the compositing in blender directly. Import your EXR files and background and composite them together, blender's compositor always works using linear data.

$\endgroup$
  • $\begingroup$ Checking "linearize working space" under Color Management under Project Settings and making sure "Preserve RGB" is checked under footage interpretation seems to fix the issue. Thanks! :) $\endgroup$ – Rolf van Dam Apr 18 '19 at 16:21
  • 1
    $\begingroup$ Nope! After Effects suffers from legacy code. The transfer function will be wrong, and it will result in a different image. $\endgroup$ – troy_s Apr 19 '19 at 17:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.