I'm wondering why the spotlight here, if I'm seeing what's going on correctly, seems to be passing right through the cube. Thanks for any ideas.enter image description here

  • $\begingroup$ Check your Lamp properties - do you have 'Shadow' enabled or disabled? $\endgroup$ Apr 18, 2019 at 6:48
  • $\begingroup$ With light selected> properties panel> object data> Shadows are enabled, but enabled or disabled here, same result as in image. Generally, with shadows enabled there, light will not pass through object, whereas with disabled shadows there, light does pass through. This is a different situation I think. I'm not really sure what I'm seeing. Thanks for any other ideas. $\endgroup$
    – frew
    Apr 18, 2019 at 17:08

1 Answer 1


For any curious about this, here's the nature of the problem and the solution at Blender bug reports. Turns out it's not a bug, but I had thought it might be, so to help by reporting it I thought I'd inquire there at Blender bug reports. https://developer.blender.org/T63768


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .