0
$\begingroup$

I worked on a character in blender 2.8 and wanted to add eyes, just like Danny Mac 3D showed in his tutorial.

https://www.youtube.com/watch?v=nPK6JlWESM8&t=397s

(sadly there isnt an eye tutorial for blender 2.8, and i want them to look good)

But when i add a material, and set the material output to cycles render, it gets pink. But i tried with an Uv Map and with unwrapping, but the pinkish color was still there. I did click on assign, but that didnt helped either.

Also finding (or reporting) missing files didnt work, since the blender console dont show where the files are. It doesnt react when i click on the 2 options.

I know blender 2.8 is beta ... but i wanted ... to try it out XD (But maybe i just miss something and its my fault)

Here are some pictures of the eyeball and the settings:

When i remove the material, the eyeball is white in LookDev, when the material is there, the eyeball is pink in render and look dev. Also the whole scene is pink xO

enter image description here

enter image description here

enter image description here

im thankful for any advice ... im really desperate since i try to fix this problem now since 1 day, and i couldnt find a solution xO

$\endgroup$
  • $\begingroup$ if you render the object any change? $\endgroup$ – ancy g1990 Apr 17 at 11:06
  • $\begingroup$ Try to change the node settings in the material output node. Change the settings in the material output node from cycles to all. $\endgroup$ – ancy g1990 Apr 17 at 11:12
  • $\begingroup$ That i can try ^^ though then i had no effect on the eye with transparent and glossy bsdf, but i will try again and tell you if it worked. (This evening) $\endgroup$ – Manuel F Apr 17 at 11:41
  • $\begingroup$ Yes it is due to your material as he mentioned that you are trying to mix transparency with nothing so.. You already have your answer there. $\endgroup$ – HDFX VFX Apr 17 at 13:50
  • $\begingroup$ now on the preview everything is good, but its still pink, though i added diffuse and transparency works ^^ $\endgroup$ – Manuel F Apr 17 at 18:07
2
$\begingroup$

The issue comes from your shader:

demo pic

Basically, you're trying to mix a transparent shader with "nothing". It's kind of trying to multiply by zero: it doesn't work well. If you set the material output to be Cycles specific while in LookDev display, it renders pink. If you go to rendered display, it will be black no matter the render engine.

So, try to add a shader into the second input of the mix shader. Or remove the mix shader completely.

If you intended to control the amount of transparency, just play with the color value:

enter image description here

$\endgroup$
  • 1
    $\begingroup$ That i will try, thanks for the answer :) thing is, it worked in the youtubers video in tutorial. I guess theres never enough go learn for me. $\endgroup$ – Manuel F Apr 17 at 12:43
  • $\begingroup$ Oh, now its like i want it to be, almost, since its still pink, but on the preview it has color and gets transparent the right way ^^ $\endgroup$ – Manuel F Apr 17 at 18:06
  • $\begingroup$ now with all it works, only thing thats left is the enviroments thats visible on the eyeball. $\endgroup$ – Manuel F Apr 17 at 19:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.