0
$\begingroup$

I am a complete Blender newb, so it's entirely possible that I am messing something up.

In this capture I am trying to select all of the "brick" objects I have created using a mouse-drag box select: Trying to select multiple objects with a box select

Am I doing something wrong? I saw some bug reports along the same lines but they don't seem to be resolved..

Windows 10, all updates installed, I JUST updated my Intel graphics driver to the latest supplied by Dell for my machine's model.

$\endgroup$
  • $\begingroup$ did you also update the sound driver? $\endgroup$ – Gerald Degeneve Apr 16 at 17:41
  • $\begingroup$ I just downloaded the newest blender, created 20 cubes by duplicating the first one and did a box select as you do ... no problem. $\endgroup$ – Gerald Degeneve Apr 16 at 17:49
  • $\begingroup$ @GeraldDegeneve while installing the graphics driver I did see some Intel Audio driver being updated, but I'm curious why that would be relevant for this? Can you also include additional details for your test? Are you also on a Windows 10 machine? Are you also using an intel integrated graphics device with the latest drivers? Can you think of any other reasons why we would be getting different behaviour? $\endgroup$ – Barak Gall Apr 16 at 18:10
  • $\begingroup$ The audio driver thing was meant as a joke since this is a funny question ;) I should have put it into other words: "Congratulations you found a bug among many!", update or downgrade to a more stable version of blender ;) Once upon a time i downloaded a version where i could not exit edit mode. it would be also worth noting, that blender settings are saved inside the blender file you are working on. so if you somehow messed up the settings you could try reseting them to their defaults. $\endgroup$ – Gerald Degeneve Apr 16 at 18:16
  • $\begingroup$ developer.blender.org/T59741 seems to be a relevant bug report. $\endgroup$ – Barak Gall Apr 16 at 18:49
0
$\begingroup$

I realized the exact same problem when using my laptop without power connected. The box selection bug happens when power is not connected and battery mode is set to "Saver" mode. When set to any other mode other than power saver, the box selection works fine. My laptop is running intel graphics HD 630/Nvidia Geforce GTX 1050.

PS. I am a beginner in Blender.

$\endgroup$
  • $\begingroup$ If you can't comment ask a question. $\endgroup$ – Lukasz-40sth Apr 28 at 8:04
  • $\begingroup$ Hey 3dken, That's an interesting issue you're having but it doesn't appear to be the case for me. I have my computer set to "Best performance" and I have the power plugged in but the issue above still occurs. I have managed to get some Blender devs to look into the issue and it seems they have identified a problem with newer Intel Graphics HD drivers. Perhaps when your machine is in power saver mode it switches the default gfx device to the Intel one which then manifests the issue for you? Check out this report for updates: developer.blender.org/T62947 $\endgroup$ – Barak Gall Apr 28 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.