1
$\begingroup$

I'm probably missing something obvious, but it seems whenever I try to move the root bone of my character after frame 35, and add a keyframe, it's being ignored. I'll scrub along the timeline to the new keyframe, but the character doesn't move to the new position that I set.

$\endgroup$
1
$\begingroup$

You have an Action strip in the NLA Editor which is overriding/controlling the animation of the object.

Here I have added a keyframe on frame 54, but because the end of the Action Strip is at 35 (green timeline marker), the keyframe is ignored:

enter image description here

To solve this you can extend the End Frame property of the Action Strip in the Properties shelf on the right of the NLA Editor (N) to be as long as your animation:

enter image description here

Or, if you don't need to use the NLA Editor, you can delete the strip by selecting the Action Strip called 'Jump' (it will be yellow/orange when selected, as shown above), press Space, type "Delete Tracks" and press Enter.

$\endgroup$
5
  • $\begingroup$ Surely all that will do is extend/draw my current animation out and slow it down...? I would have thought the amount of the Action Strip's frames would keep increasing as I add more keyframes...? I don't recall setting it to 35 at the start... $\endgroup$ – DustyShinigami Apr 16 '19 at 16:08
  • $\begingroup$ I've just increased the end frame to 60, but any frames I add after 35 don't register either. $\endgroup$ – DustyShinigami Apr 16 '19 at 16:11
  • $\begingroup$ It doesn't slow the animation down it sets the range of where to look for keyframes within the original action. The exact steps I take with your file is to change to NLA, select 'Jump' strip, extend range, add new keyframe and it works. $\endgroup$ – Ray Mairlot Apr 16 '19 at 16:17
  • $\begingroup$ Note that the panel in the screenshot is 'Active Clip' not 'Active Strip'. There are two panels that look quite similar and both have frame range options. $\endgroup$ – Ray Mairlot Apr 16 '19 at 16:23
  • $\begingroup$ Ahaa... That's why I couldn't get it to work; I was adjusting the Active Strip. That worked. Thanks. :) $\endgroup$ – DustyShinigami Apr 16 '19 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.