1
$\begingroup$

enter image description here

I want to create an animation using rigid body physics, but I encounter this problem..., the objects pass trough the wall... What settings should I apply?

I checked the normals, the scale, object weight, I tried to increased Steps per seconds and solver iterations, but still have same problem.

$\endgroup$
1
  • $\begingroup$ Can you please upload your file? $\endgroup$
    – Nicola Sap
    Apr 23 '19 at 13:30
3
$\begingroup$

You're going to have to increase the Steps per second a bit more. The motion of the box is too fast, and the spheres may find themselves suddenly "out" of the box (or inside the wall!) in the next solver's step, when in the previous they were inside.

The solution is to have another step in-between so that the collision is not inadvertently skipped, and in this intermediate solver's step the sphere is just next to the boundary, and it feels the collision force kicking it back in. This is what "Steps per second" does.

Increasing the solver iterations further can also help.

$\endgroup$
1
  • 1
    $\begingroup$ In my experience, if your "Steps per second" is less than around 300, do not bother increasing iterations. I get nice results with setting steps to 200-300 and iterations to 1-2. In addition, setting "Steps per second" too high (e.g. 1000) results in incorrect simulations, too. For example, a bouncy ball colliding with a flat surface may end up bouncing slightly in wrong direction if "Steps per second" is too high. $\endgroup$ Oct 20 '20 at 12:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.