0
$\begingroup$

When skinning a model, you can do a weight painting and then add a subsurf modifier to smoothly interpolate the vertices. To do this I have the subsurface modifier below the armature modifier on the stack.

Now when exporting the model, this smooth interpolation doesn't seem to get applied to the vertices. Instead I get the same effect as when subsurf modifier is above armature modifier on the stack. Is there a way to apply the interpolated weights on export?

I'm using a custom export script, where I apply modifiers in this succession: mirror modifier, armature, subsurf modifier.

$\endgroup$
  • $\begingroup$ There is a feature in blender 2.79/2.80, "Smooth Vertex Weight" which you can access from the search menu when you are in the Weight Paint mode. $\endgroup$ – 3DSinghVFX Apr 14 at 12:48
  • $\begingroup$ @3DSinghVFX: Thanks! But when do I use this? After applying subsurf or before? $\endgroup$ – Lenny White Apr 14 at 21:13
  • $\begingroup$ You do not need to apply subsurf modifier to smooth the vertex weight. This option allows you to smooth the vertex weight. $\endgroup$ – 3DSinghVFX Apr 14 at 21:18
  • $\begingroup$ @3DSinghVFX: In my workflow I usually first assign vertex weights and then add subsurf modifier. When applying it I want the weight to get smoothly interpolated between original vertices. So I should use the "smooth vertex weight" after applying the subsurf right? $\endgroup$ – Lenny White Apr 14 at 21:36
  • $\begingroup$ Yes, then use the "smooth vertex weight" after applying the subsurf modifier. $\endgroup$ – 3DSinghVFX Apr 14 at 21:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.