0
$\begingroup$

The influence of the bone I created is set to 0, the animation does not work when I set it to 1 again.

video : https://www.youtube.com/watch?v=8w2DARNBwQw&feature=youtu.be

$\endgroup$
  • 2
    $\begingroup$ Hello! Please do not link to external video to describe your issue, please describe your issue with words and images in the question. You will find that you will have better engagement with your questions when you do so. You can also include a .blend file if you want to get to the point $\endgroup$ – Kirbinator Apr 12 at 19:58
  • 1
    $\begingroup$ Please use the edit link at the bottom of your question and add images that might help us understand your scene and settings. See How to upload an image to a post?. If you want to upload your file, please use blend-exchange and add the given link to your question. $\endgroup$ – metaphor_set Apr 12 at 22:02
  • $\begingroup$ Depending on whether the animation is part of a larger project or not, I try to keep it free of constraints and 'active' modifiers where possible. The "Child of" constraint is one I've yet to use successfully without it coming back to bite me. In cases such as yours I animate the clip and weapon as a separate animation using keyframes only and adding the charatacter later. It's the clip and weapon that moves the wrists (lower arm bone) and character, not the other way around. The character, weapon and spent clip are all separately grouped within their respective 'Navigation Empties'. $\endgroup$ – Edgel3D Apr 21 at 4:43
  • $\begingroup$ Further to the above links to 2 small (mp4) videos - dropbox.com/s/06nau731ci59vwn/Assault.mp4?dl=0 dropbox.com/s/8kh9wwp5pj6lmev/Assault2.mp4?dl=0 ... If asked to log in, click in an empty space $\endgroup$ – Edgel3D Apr 21 at 6:46
0
$\begingroup$

Thank you for describing your question very clearly. constraint is set to 1. Go to the frame where you want the constraint to be zero. Type zero on the constraint modifier, while you mouse hover on the number press "I" to INSERT a keyframe. Your number field will change color to yellow, thus effectively inserting a keyframe (0 zero) on that specific frame. You are doing all right, just needed to set the keyframe to zero since all keyframes after the frame you need are set to 1.

If you find this is the answer, thank you for your consideration to vote me as the answer by clicking to the left :the icon with a check mark and upvote this answer.

BFCT_Schiller

$\endgroup$
  • $\begingroup$ not working, same problem $\endgroup$ – KapitaN Apr 13 at 10:58
  • $\begingroup$ target and pole target are empty. Basically you have not setup IK modifier correctly. That´s why it´s showing red. I thought you knew you set it up. $\endgroup$ – Pierre Schiller Apr 13 at 12:12
  • $\begingroup$ but the problem is not there, working on other projects $\endgroup$ – KapitaN Apr 13 at 13:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.