1
$\begingroup$

I am trying to make a simulation where I have a container and it is getting filled with more rigid bodies (Soccerballs) falling from above. The container gets filled fine but when I try to animate the container itself from one location to another the contained Rigidbodies spill out from the containers sides ..

the soccerballs are relativly small in size, I don't know if this is the reason for the problem.

I have tried the following solutions but with no use, balls still spill out from the container.

1- I have changed the container collision shape sensitivity margin. 2- I have changed the balls collision shape(the problem got worse) 3- I have tried changing friction and bounciness of the balls

How can I solve this problem, what settings can I change that might help?

thanks in advance for your answers, I am sorry that the question got too long.

$\endgroup$
  • $\begingroup$ I was able to solve the problem by slowing down the animation, I changed the movement of the container from 24 frames to 44 frames.. the problem was that the container is moving to fast.. I still want to know how to get the rigid bodies to stay contained while moving the container fast in the animation. $\endgroup$ – Raymond Gabriel Apr 11 at 12:06
  • $\begingroup$ Feel free to answer your own question and mark it as resolved as to help others with your problem $\endgroup$ – Kirbinator Apr 11 at 19:31
0
$\begingroup$

Within the Scene properties are the Rigid Body World settings. This includes a Steps Per Second property. This setting determines how often blender should check the position of objects in the scene for how they should interact - faster moving objects require a larger number of steps to prevent them passing through each other before Blender detects the collision.

$\endgroup$
  • $\begingroup$ Thanks Rich for your answer, unfortunately, I have tried the solution you have mentioned but it resulted in weird behavior from the rigid bodies. $\endgroup$ – Raymond Gabriel Apr 11 at 20:28
  • $\begingroup$ @RaymondGabriel Another thing to try is to ensure the Scale of your object is “applied” by selecting them, pressing Ctrl+A and selecting Scale. $\endgroup$ – Rich Sedman Apr 11 at 20:39
0
$\begingroup$

I was able to complete the project without problem when I slowed down the movement of the rigid body container, I think that gave blender more time to be able to calculate the collision between the rigid bodies.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.