1
$\begingroup$

Why are these black lines appearing in the render when I'm using Cycles? How can I remove them? Thanks!

image

Update: the object is not using textures and the problem persists. This screenshot shows the mesh.

How I created the model: I selected a face from the stones model, I separated the face with "p" -> Selection, then I extruded it, I removed the old texture assignation, however a new object like a box is clear, so it seems there's a "link" with old parameters taken from the separation.

image2

Update 2:

This is what happens if I create a new texture, with an image and the UV unwrap.

image3

Update 3:

I created a new scene, I pasted there the object and the problem persists. Then I do the following:

  • Cursor to Center

  • Selection to Cursor

  • Geometry to origin

Guess what? The lines disappear. The problem is not fixed because I don't want the object at the center of the workspace. It's for a big scene, about 400 m x 500 m.

$\endgroup$
5
  • $\begingroup$ could you please share the object? $\endgroup$
    – moonboots
    Apr 11, 2019 at 7:21
  • 1
    $\begingroup$ Please update your questions with additional information regarding how the material nodes, whether you're using UVs, the UV map - anything that might help determine the problem. $\endgroup$ Apr 11, 2019 at 8:00
  • $\begingroup$ The way the lines are shaped definitely looks like a texture forgotten somewhere. Baked lighting perhaps? $\endgroup$ Apr 11, 2019 at 11:45
  • $\begingroup$ Or bad mapping. Try a generated or object mapping instead of UV (default) or unwrap to get new UV $\endgroup$
    – Bithur
    Apr 11, 2019 at 12:02
  • 2
    $\begingroup$ i had a similar problem here with the same kind of fix (change of origin and back to world origin) $\endgroup$
    – Bithur
    Apr 11, 2019 at 13:45

1 Answer 1

2
$\begingroup$

Solution: select the object, and then select the option:

Object -> Transform -> Origin to Geometry.

This solution is similar to the @Bithur's comment.

I don't know why it happens, but it seems Blender could have a little bug about handling textures when the objects are too far from the workspace center. For sure it's not a feature.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .