1
$\begingroup$

I have a model with an open mesh terrain surface and some closed building meshes – when rendering in Cycles I'm seeing black streaks along some mesh edges.

On the building models it seems to be wherever there's a concave edge connecting two faces, on the terrain it's less clear but I think also at concave edges:

enter image description here

What is causing this??

Edit: Here's what the material nodes look like: enter image description here

And how it appears in a full render: enter image description here

Also, after duplicating and separating out a section of the terrain mesh for clarity, and correcting the normals: enter image description here

Blendfile:

$\endgroup$
  • $\begingroup$ Is this image from a view window in rendered mode? Does it do this on a full render? Can you show the material node graph? $\endgroup$ – Kirbinator Apr 10 at 15:07
  • $\begingroup$ Could you share your blendfile? $\endgroup$ – Bithur Apr 11 at 12:10
  • $\begingroup$ added a link at the bottom of the original question $\endgroup$ – carstoid Apr 11 at 12:25
1
$\begingroup$

Your scene was hard to use. I had to change things.
- applied scale of everything
- changed the origins to geometry
- moved everything back to world origin (35km away on X, 7km on Y)
It seems to fix the artifacts.

I can't tell exactly what happened but it is probably because blender has some limits calculating surfaces with big numbers like that (scale issue).

I also change unit system, unit scale, disconnected HDR world texture and propably a few things here and there while testing...

$\endgroup$
  • $\begingroup$ Amazing! Thanks so much for troubleshooting this. Going to just spell out a few things here to help other people find this if they're having the same problem – the scene geometry here is derived from GIS data, in a State Plane Coordinate System. In other modeling software like Rhino it's not uncommon to maintain the origin/units from this rather than an arbitrary origin based on your geometry. But, as @Bithur points out, Blender has trouble with these large coordinate values so it's better to establish a project-specific origin. $\endgroup$ – carstoid Apr 11 at 15:07
  • $\begingroup$ Glad to help :) It's also easier for navigation. With the option "rotate around selection" and object's origin kms away it was a bit hard to move the view in object mode. I think i can help with clipping too $\endgroup$ – Bithur Apr 11 at 16:43
4
$\begingroup$

You need to recalculate the normals of your mesh.
go in edit mode with TAB
select all with A 1 time, or 2 times, or 3 times (depending on if something is selected and if you're using 2.79 or 2.8)
- If you're using 2.79 or earlier, use Ctrl+N (recalculate outside) or Shift+Ctrl+N (recalculate inside)
- If you're using 2.8, Shift+N (recalculate outside) or Shift+Ctrl+N (recalculate inside) recalculate normals

$\endgroup$
  • $\begingroup$ You'll find many questions and answers about normals if you want to know more about them. This answer is just an update because of 2.8 changing keyboard shortcuts. more about normals $\endgroup$ – Bithur Apr 10 at 14:40
  • $\begingroup$ I'll take a look at the link, thanks for sharing. After recalculating the normals though things are looking more or less the same, see updated post above. Any other ideas? Could having an irregular mesh topology have something to do with it? $\endgroup$ – carstoid Apr 11 at 12:06
  • $\begingroup$ Also, using the smooth tool on the mesh makes many of the streaks go away, but on others it just moves them around... $\endgroup$ – carstoid Apr 11 at 12:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.