0
$\begingroup$

As you can see below, when I select the mesh that uses my material the transparency works, but when I deselect the mesh or render the scene there is a halo of color around the black lines on the texture.

The color matches the background of the scene regardless of the color, so it doesn't seem to have anything to do with the texture itself. I've got similar textures working without this problem in other blend files.

Any ideas? enter image description here

Edit: I've also noticed that even the grid lines are visible. It's like the transparency mask is ignoring the mesh directly behind it right around the black lines in the texture. enter image description here

Here is a look at the material and texture settings: enter image description here enter image description here

$\endgroup$
  • $\begingroup$ To clarify your situation your images should have more focus on your transparency settings. Please state Blender Version you are using. I see the Blender Render. The transparency settings are useful to see. $\endgroup$ – atomicbezierslinger Apr 9 at 0:38
  • $\begingroup$ @atomicbezierslinger thanks for the comment, and apologies for not including enough information in the original question. It's the strangest thing because the exact same settings work perfectly on a different transparent texture in another blend file. I've edited the original post to show my settings. $\endgroup$ – Tyler Apr 9 at 1:07
  • $\begingroup$ With the Use Alpha setting ....Try premultiplied. Rather than straight. Unfortunately my time is running out at this time. Otherwise try the other texture for explanation purposes. Did these texture come from the same source for explanation purposes? $\endgroup$ – atomicbezierslinger Apr 9 at 1:45
  • 1
    $\begingroup$ In the transparent object's properties go down to the display tab. In there is a box called "Transparency" Ticking or unticking that may solve your problem. $\endgroup$ – Edgel3D Apr 10 at 7:08
  • $\begingroup$ You sir are a genius, @Edgel3D ! That worked like a charm! You should post that as an answer so I can give you an upvote and mark it as the solution! $\endgroup$ – Tyler Apr 11 at 3:48
1
$\begingroup$

In the transparent object's properties go down to the display tab. In there is a box called "Transparency" Ticking or unticking that may solve your problem.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.