0
$\begingroup$

I've made multiple individual objects and joined them when I try to rotate a bone the joined objects don't move.

enter image description here

$\endgroup$
2
  • $\begingroup$ Did you join before or after rigging the original object? did you assign the "mesh" to the right bones? $\endgroup$
    – Georges D
    Apr 8 '19 at 16:51
  • $\begingroup$ I joined them after rigging $\endgroup$ Apr 9 '19 at 2:53
1
$\begingroup$

You've probably parented the mesh to the skeleton before joining additional parts to it. Thus vertices of the new parts don't belong to any vertices groups, created by "Parent with automatic weights" operation. If it's only about the helmet, the easiest way to fix that would be to separate it again from the body mesh and parent it to the head bone. If you're planning to add some equipment also to the chest, usually the way to go about it would be to keep that separate and use Mesh Deform modifier to control the character, cause it's usually hard to get perfect weights on fragments that are not physically connected (not just joined, but with common edges) with the main mesh.

$\endgroup$
2
  • $\begingroup$ Hey how can I select the head bone, when I'm trying to select all my bones are getting selected so I can't join the helmet to the head bone $\endgroup$ Apr 9 '19 at 4:20
  • $\begingroup$ I figured it out thanks for the help, It'll work for me :) $\endgroup$ Apr 9 '19 at 4:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.