0
$\begingroup$

I can't seem to get my emission shaders' reflections to cast on my model unless the emission shader's surface is actually in view.

emission shader working properly Here I obscure the view of the surface I have the emission shader on from the first image and it no longer casts light on the rest of the model above it.

emission shader not working I assumed I need an irradiance volume to get the reflections to work but after baking I still don't get any light out of it.

Irradiance Volume not working I'm sure I'm missing something here but after extensive searching I just can't figure it out. Would appreciate some help.

Edit: As far as I can tell, an irradiance volume should solve this issue, but it simply doesn't. Maybe Eevee isn't able to cast emissions if the emission itself is out of view but I can't find confirmation on that anywhere.

Edit 2: After more testing I still can't figure this out and I haven't received any useful replies. I'm fairly confident now that there's no way around this issue until the developers provide a solution.

$\endgroup$
0
$\begingroup$

You seem to be mistaking your bloom effect with indirect lighting.

bloom
Left: Indirect lighting, Right: Bloom

Bloom will not be visible once an object disappears from view (e.g. when the camera angle changes). The indirect lighting is very faint in your example since the emissive area is very small and the illumated surfaces are at a 90° angle.

However, even increasing the brightness of the emissive material won't help much if the samples of the light probe are too few. You will quickly get unnatural artefacts.

enter image description here

A solution could be to use a very dense light probe and a very bright emissive light. You will have to reduce/adjust the bloom effect which will be even brighter then.

![many smaples Many samples.

But as you can see, there are some artefacts. Light probes are not very useful for very small emissive lightemitting meshes. A real solution would be, to reproduce the emission with normal lamps.

$\endgroup$
  • $\begingroup$ Thank you for the detailed explanation. That makes total sense. I was forgetting about the bloom effect. It's unfortunate that bloom can't be baked in like other indirect lighting. I will have to find a workaround. $\endgroup$ – John Abraham Apr 20 '19 at 3:17
0
$\begingroup$

Overscan can help a little bit. You can turn it on in the render settings>>film. The max value with typing is 50%, so the range of the reflection visibility will be increased by a half image. enter image description here

$\endgroup$
  • $\begingroup$ That doesn't seem to do it either. I think that will only reflect the object itself, not its light. $\endgroup$ – John Abraham Apr 6 '19 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.