4
$\begingroup$

When I hit Alt+A to animate the smoke simulation, I just get the particle effect without seeing the smoke. As you can see from the screen shot. I am now using 2.67b. Can somebody please tell me why it's happening as every time I wish to see the changes I have made I have to render the scene which takes a long time and is slowing me down.

enter image description here

As you can see from above left (blender 2.67b) when I hit Alt+A no smoke appears in the simulation. The image to the right with smoke is done with blender 2.62,

$\endgroup$
  • 1
    $\begingroup$ Please ask a specific question. Your issue could be cause by a multitude of things. This is more of a debugging thing that is not easily fixed in a question. Try simulating a different object, simulating in a different file (by appending), clearing out the cache and baking again, in different versions and using another persons successful bake. You can eventually narrow down the issue. If you think this is a bug, please report it to the Blender Bug tracker: blender.org/development/report-a-bug $\endgroup$ – CharlesL Jun 25 '13 at 13:05
  • $\begingroup$ I think we are eager to figure out what's causing this @Lindsey, perhaps if you really want to figure this out you could help is a little by giving a step by step list of what you do. Edit the question to include these steps and we'll have more to go on. $\endgroup$ – zeffii Jun 25 '13 at 22:17
1
$\begingroup$

I figured out that, as soon an particle system is involved in the scene and you need to render the smoke / fire, you have to start an animation from frame one to get the smoke displayed.

$\endgroup$
  • $\begingroup$ I started by setting an emitter with a particle system on, I then placed a smoke flow from the physics panel, then a cube around my flow mesh and set this up as a domain, from the physics panel. I baked all dynamics from the smoke domain cache panel. When this was done, pressed Alt A and the animation played as particles rather than seeing the smoke, as shown previously on my screen shot. When I press F12 the fully rendered frame is displayed with the smoke as it should be. I have tried different objects and settings. I have even tried this with the quick smoke simulation all with no joy. $\endgroup$ – Lindsey Jun 27 '13 at 12:54
  • $\begingroup$ I have also set up the material as a volume and set the denisity to o.o. I have set up the texture as a voxel data texture and evetything seems to be fine except i cannot see the smoke on the 3d screen., $\endgroup$ – Lindsey Jun 27 '13 at 13:21
  • $\begingroup$ Maybe this tutorial will help you. Don't wonder too much about its has an explosion as the main topic. It will cover the creation of smoke very well. blenderguru.com/videos/how-to-create-an-explosion $\endgroup$ – common sense Jul 1 '13 at 21:30
1
$\begingroup$

It sounds like something might be hidden in the viewport.

Have you checked these places?

enter image description here enter image description here

In case images don't show up, they are at http://i.stack.imgur.com/OYGx8.png and http://i.stack.imgur.com/cxoXn.png

$\endgroup$
  • $\begingroup$ no images are being displayed on your answer can you upload again. cheers. $\endgroup$ – Lindsey Jun 28 '13 at 8:20
  • $\begingroup$ @Lindsey hmm.. they work fine for me..? added direct links to the images. $\endgroup$ – gandalf3 Jun 29 '13 at 0:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.