3
$\begingroup$

I just upgraded from Blender 2.69 to 2.71. I loaded my previous save file and found, to my dismay, that my pose no longer displayed properly. I'm using Makehuman version 1.0.0. It appears that FK still functions as expected, but IK does not. IK hand and foot targets do not affect arm and leg placement. The root bone appeared to work.

Any ideas how I can (preferably) revive my save files with the new version? Alternatively, is there a way I can export the pose from 2.69, save in the neutral position, then re-import the pose in 2.71? I don't see any export options for poses in 2.69.

$\endgroup$
  • $\begingroup$ Do you use a Mhx rig or Rigify, Mhx's FK still works for me. $\endgroup$ – stacker Jun 30 '14 at 6:01
  • $\begingroup$ Is it possible some drivers are being blocked? $\endgroup$ – gandalf3 Jun 30 '14 at 18:37
  • $\begingroup$ I use an MHX rig. The FK does work, but IK does not. I'm interested far more in IK, as I find it much easier to use. :) I am unsure what you mean by drivers being blocked. If you mean my OS is blocking the operation of some part of Blender, I think that is unlikely. $\endgroup$ – TurtlesAreCool Jul 1 '14 at 13:58
  • $\begingroup$ EDIT: I believe you mean the "MHX drivers", which I can see in the properties panel. I don't see anything that appears different in 2.69. And I do have IK enabled in the FK/IK switch. $\endgroup$ – TurtlesAreCool Jul 1 '14 at 14:03
  • $\begingroup$ As a Stack Exchange noob, I wish I could edit comments more than 5 minutes out. --- @gandalf3 - I think you are right. Blender itself was blocking the driver. I just noticed a little message on the status bar. I said "reload trusted", and the pose is working. This may also have to do with the fact that I had "auto-run python scripts" disabled. I think this is resolved. I'm not sure if I'm supposed to retype this info in an answer and credit you? $\endgroup$ – TurtlesAreCool Jul 1 '14 at 14:16
2
$\begingroup$

If you had auto run python scripts enabled in your preferences for 2.69 and you haven't enabled it or copied your user prefs in the new version, then it might be because some python drivers are being blocked.

If this is the case, there should be a message in the info header (at the top of the window by default):

enter image description here

You can either press Reload trusted each time you open the .blend, or make sure auto run python scripts is enabled in User preferences > File > Auto Execution:

enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.