24
$\begingroup$

I was working just fine and suddenly when I changed from object to Edit Mode, neither vertices, edges nor faces were highlighted as usual.

I can still select them but can't see them, the object is displayed as in object mode. It happens with all my objects in the scene. Does anybody know why this could happen? I'm using 2.8

enter image description here

This is my viewport. I have one edge selected

$\endgroup$
8
  • 2
    $\begingroup$ Could you post a screenshot of what you're seeing please? $\endgroup$ Commented Apr 4, 2019 at 10:25
  • $\begingroup$ I posted it in an answer to the original post, I didn't know if I could answer just to you, I'm kinda new... $\endgroup$ Commented Apr 4, 2019 at 10:30
  • $\begingroup$ Sorry I wasn't clear. You should include the image as part of your question. To edit your question, click the "edit" button at the bottom left of your question. (only answers should be posted as answers.) Thanks! $\endgroup$ Commented Apr 4, 2019 at 10:42
  • $\begingroup$ I didn't know I could do that, sorry! $\endgroup$ Commented Apr 4, 2019 at 10:45
  • $\begingroup$ It's alright, thank you! The problem could be a modifier (solidify, perhaps?). Do you have any modifiers set up? $\endgroup$ Commented Apr 4, 2019 at 10:52

8 Answers 8

33
$\begingroup$

The problem is that OVERLAYS is turned off, this feature is added in Blender 2.8, press the icon that looks like two intersecting circles next to Overlays.
enter image description here
In your image, it appears at the bottom of the 3D Viewport, by default it's at the top.

$\endgroup$
3
  • 1
    $\begingroup$ omg thanks! I've been stuck for half an hour $\endgroup$ Commented Apr 4, 2019 at 10:59
  • 1
    $\begingroup$ Glad I could help :) $\endgroup$
    – Georges D
    Commented Apr 4, 2019 at 10:59
  • $\begingroup$ Thanks, It helped me. $\endgroup$
    – Auvee
    Commented May 6 at 18:09
4
$\begingroup$

I just had this same problem, but Overlays was turned on. The problem was that in the Subsurface modifier the Optimal Display box was checked. I unchecked it and the mesh appeared instantly.

$\endgroup$
1
$\begingroup$

you have to click on the small button at the right bottom corner this small button at the left side of „overlays“ and on this button there are two spheres

Your problem was that you unchecked overlays so you can‘t see the wireframe of the object

$\endgroup$
1
$\begingroup$

I nearly had the same problem, i couldnt see any vertices i selected. The solution was to go to the viewport shading panel and check the backface culling in the options.

$\endgroup$
1
$\begingroup$

I just want to add I had a problem with this too but the solution for me was different from anything anyone else has said. To fix it for me, I had to change the OFFSET of the SOLIDIFY modifier to a NEGATIVE value. When it is positive, I cannot see the vertices. Hope this is helpful to anyone.

$\endgroup$
1
$\begingroup$

I had the same problem but none of these solutions worked, in my case the selected mode was set to Edge select, so the solution was simply return to the Vertex select, as shown in the image below, but anyways learned that there's a lot of ways to turn those vertices of, though. enter image description here

$\endgroup$
0
$\begingroup$

I realised that was editing a shapekey instead of selecting base shape.

Allways be sure you are editing the base shape not shape key.

$\endgroup$
0
$\begingroup$

In my case in needed to deactivate and activate the X-Ray mode (squares, top right).

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .