Here is the scene setup which I will explain further: Scene Setup in EEVEE with probes ## Heading ## What you see in the screenshot above:

  • Lit in yellow is the irradiance volume
  • You see a circle of lights that can be switched between spot and point with one button. These lights are in the big box for indirect light. You see a small cube on a floor and there are some open walls around the floor.
  • The big cube, use for indirect lighting and doesn't have to be necessarily part of the final render.
  • Lit in yellow is the irradiance volume.


When I set all lights to spot, the walls of the big box are not so much lit, and when I take a look inside the small box, it's pretty dark in there. Just a little or no light leak.

But when I set the lights to spot, the walls of the big box will be fully lit and when I take a look after baking, it is quite lite inside the small box.


Is it normal? It doesn't look like light leaks but it is quite light in there like ambient light. Here two screenshots of what you see inside the box. The first is baked indirect with spotlights, and the second with point lights.

Baked with spot-lights

Baked with point lights


Here some specifications of the settings;

bpy.context.scene.render.engine = 'BLENDER_EEVEE'
bpy.context.scene.eevee.taa_render_samples = 256
bpy.context.scene.eevee.use_gtao = False
bpy.context.scene.eevee.use_bloom = False
bpy.context.scene.eevee.use_ssr = True
bpy.context.scene.eevee.use_ssr_halfres = False
bpy.context.scene.eevee.ssr_quality = 1
bpy.context.scene.eevee.ssr_max_roughness = 0.5
bpy.context.scene.eevee.ssr_thickness = 0.2
bpy.context.scene.eevee.ssr_border_fade = 0.075
bpy.context.scene.eevee.ssr_firefly_fac = 10
bpy.context.scene.eevee.shadow_method = 'VSM'
bpy.context.scene.eevee.shadow_cube_size = '1024'
bpy.context.scene.eevee.shadow_cascade_size = '1024'
bpy.context.scene.eevee.use_shadow_high_bitdepth = True
bpy.context.scene.eevee.use_soft_shadows = True
bpy.context.scene.eevee.light_threshold = 0.01
bpy.context.scene.eevee.gi_diffuse_bounces = 3
bpy.context.scene.eevee.gi_cubemap_resolution = '512'
bpy.context.scene.eevee.gi_visibility_resolution = '32'
bpy.context.scene.eevee.gi_irradiance_smoothing = 1
bpy.context.scene.eevee.gi_glossy_clamp = 0
bpy.context.scene.eevee.gi_filter_quality = 1
bpy.context.scene.eevee.gi_cubemap_display_size = 0.3
bpy.context.scene.eevee.gi_irradiance_display_size = 0.1
bpy.context.scene.eevee.use_overscan = True
bpy.context.scene.view_settings.view_transform = 'Filmic'
bpy.context.scene.view_settings.look = 'Filmic - Base Contrast'
bpy.context.scene.view_settings.exposure = 0
bpy.context.scene.view_settings.gamma = 1

Settings for irradiance volume;

Distance: 2m Fallof: 0.00 Intensity:0.75 Resolution: all on 4 Clipping Start: 0.01 End: 40m

visibility: Bias: 1.00 Bleed bias: 0 Blur: 0.2 Visbility collection: N/A

Settings for light: Shadow: Clip sstart 0.1 Softness: 1.00 Bias: 0.2 Exponent: 2.5 Bleed Bias: 0.5

Contact shadows; Distance 0.6 Softness: 1.5 Bias: 0.02 Thinkness: 0.2


1 Answer 1


I found the answer myself.
In the properties panel there is a tab where you can find settings for the Irradiance Volume. enter image description here

Under Visibility Collection you can exclude a collection. So In this case we add the cube to a collection (called test here) and when you bake indirect light now, everything will look the same from outside the cube, but inside the cube its now pretty dark.


You must log in to answer this question.