0
$\begingroup$

Object moving on it’s own when rendered! (EEVEE)

In the cli[ you can see that the head is bubbling/moving. This when the head had no keyframes,no empty, no link to anything. It only has a Bevel and Sub. Modifier.

Does anyone have any idea why this happens? I checked the internet but most there was related to an Empty or keyframe.

I haven’t used the boolean. It was build up with a plane. Used the modifiers and some edge bevel weights. And started out with a mirror but had applied that early in the process I looked for doubles but there were zero. Also, I had applied the modifiers and rendered again but the same result? Ad when applying the modifiers the memory does up 3G :shushing_face:

I just don’t get it. I had this one before when I had made an octopus. In the end, I rendered every frame single handle that had a defense. But that is a hell of a job.

I just don’t get it? See clip https://youtu.be/o8xzt7JRPgQ

Oh and the material is just a simple principled shader. Nothing extra

$\endgroup$
  • $\begingroup$ The camera is moving, not the object... $\endgroup$ – thibsert Apr 2 '19 at 10:24
  • $\begingroup$ @thibsert I know the camera moves :) But the object moves bubbling out of itself when rendered. See clip youtu.be/o8xzt7JRPgQ $\endgroup$ – Ivo Schoenmakers Apr 2 '19 at 11:59
  • $\begingroup$ Sorry, didn't see the video :) $\endgroup$ – thibsert Apr 2 '19 at 14:01
  • $\begingroup$ I found what caused it, I replied to OP on Facebook and posted an answer here. $\endgroup$ – kheetor Apr 3 '19 at 11:30
1
$\begingroup$

I fiddled with the .blend and inspected rendering results between frames around 30-34 which were shading inconsistently. Turns out it's not about geometry or animations but the culprit is unused / misused Displacement-slot on the Material Output node of the material. Removing the connection (from multiply node and empty image node) to the Displacement slot solved the rendering issue. This slot should behave properly with an actual texture, you have to be feed it very small numbers. But I wouldn't be surprised if this feature was still a little bit unstable with Eevee.

| improve this answer | |
$\endgroup$
  • $\begingroup$ @ Kheetor I really feel stupid now, missing something like that. Thank you so muts for taking your time to look it up and finding my mistake!!!! The Displacement was not needed for the scene. So i deleted it. Now it rendered just fin Again many thanks for taking your time to find my error :) $\endgroup$ – Ivo Schoenmakers Apr 8 '19 at 12:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.