1
$\begingroup$

I have 2 Walls and a lamp in between them. The walls stays close to the floor, there is nothing between but the light is shinning through which is completely nonsense. How to prevent this behavior?

enter image description here

$\endgroup$
  • $\begingroup$ It probably won't look very good, and if you start doing it to all your lamps there will be a performance hit - but you can try giving each lamp a shadow. The spectacular on your ground plane still might look wierd behind the wall, but at least there will be no direct light shining on it. $\endgroup$ – X-27 wants to Reinstate Monica Apr 1 at 18:08
  • $\begingroup$ Thank you, i tried that right now. But if i do that (hopefully i did it right) it looks like there is no specularity at all, so wouldnt it be better to turn off specularity in this case? $\endgroup$ – MBrain Apr 1 at 21:34
  • $\begingroup$ My solution is to either lay a duplicate ground (plane) a little above the original and either break it in 2 or trim or shape it's adjoining edge where the ight is leaking through. Place that duplicate in a separate layer and set the lamp(s) to "This Layer Only", Duplicate the main lamp from the 1st layer into the 2nd so the ambient lighting is identical. I'll drop a short video up on Dropbox. It's too large for here when GIF'd. Note - almost all of my rendering is in OpenGL and that can sometimes appear different to Blender Render and certainly will with Cycles. $\endgroup$ – Edgel3D Apr 3 at 2:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.