1
$\begingroup$

After I was done modelling almost all the parts, I increased the view count in subdivision surface modifier and applied to all of the meshes. Now when I toggle to the edit mode, there are thousands of faces on the mesh. Anyone knows how to solve it? thanks in advance. (UNDOs not available)The following image has face selected in edit mode.

$\endgroup$
1
$\begingroup$

It is true that you probably don't need 3 million triangles for such a simple object (You should try to avoid excessive subdivisions read: Blender render crash when using subsurf modifiers.).

Did you actually apply the modifier, or just added the modifier to the object? In other words, did you make the subdivision permanent by hitting the Apply box on the modifier?

enter image description here

If you didn't apply, the modification is still editable, and you can just dial down the number of subdivisions in the modifiers.

If you actually applied the modifier, you can use the decimate modifier with the option to Un-Subdivide. Move the number of iterations to the number of subdivisions you want to get rid of.

enter image description here

Modifiers are designed so that you can work in a non-destructive way, so that you can make some operations without making them permanent. Unless you have a compelling reason to Apply the modifier, you can keep them as modifiers.

Another sometimes overlooked feature of modifiers is the ability to turn them off so that you can continue editing the object:

Modifiers have a few switches to control them:

enter image description here

The Camera icon enables or disables rendering using the modifier.

The Eye icon toggles visibility on the 3D viewport.

The Dotted Square (or Box) toggles visibility in Edit mode.

The Triangle, when enabled, will show the final modified geometry in Edit Mode and can be edited directly. (This last option can only be used when visibility in Edit mode has been enabled)

To learn about all of the other options for modifiers please read:

https://www.blender.org/manual/modeling/modifiers/introduction.html#interface

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.