1
$\begingroup$

I have a walk cycle that plays at correct speed in the 3D viewport. But after making a final video the video plays too fast. This fast speed happens whether I use FFmpeg or AVI jpeg. Nothing changes when I alter the fps from 29.97 to 60.

I should say that my timeline is set to 'no sync' which is what it's always been set to. However, when I change the timeline setting to 'frame dropping' or 'AV sync' I can see the speed in the 3D viewport plays at the same speed as the final rendered videos (which is way too fast).

I've had this problem for a week and can't find the answer. Any help would be greatly appreciated.

$\endgroup$
  • $\begingroup$ No Sync plays all the frames with no respect for the final speed, whereas Frame Dropping plays at the final speed at the cost of some frames, so it's this option that you should enable. So if the final rendered speed is too fast, you need to reduce the speed of your animations in your dopesheet. $\endgroup$ – moonboots Apr 1 at 14:19
  • $\begingroup$ I have 3 dope sheets working together so stretching them would be a very involved process. I know the makers of Blender didn't put in 'no sync' as a rabbit hole for people like me to end up in because 'so sync' is a default setting. Isn't there a way for me to render from what currently I have? This software is so quirky. $\endgroup$ – genkaiten Apr 1 at 14:27
  • $\begingroup$ @genkaiten There is a global time remapping setting you can use to globally speed everything up or down. It's a little wonky to tweak by eye (it does weird things to what the timeline shows), but if you can see what framerate your playback is going at in "No Sync" mode that should give you an idea for the "old" value. $\endgroup$ – gandalf3 Apr 1 at 14:31
  • $\begingroup$ what do you mean when you say that you have 3 dopesheets? If you press the "Only Include Channels Relating to Selected Objects" option (arrow icon on the dopesheet horizontal bar), select all the objects/armature that are supposed to be slowed down, put the green arrow where the deceleration is supposed to begin, put your cursor on the right and press ctrl right clic to select all the keyframes on the right, then you just stretch the whole thing with S (scale) $\endgroup$ – moonboots Apr 1 at 14:32
  • $\begingroup$ That said, altering the FPS should have an effect on video output. How are you playing the rendered video back? $\endgroup$ – gandalf3 Apr 1 at 14:33
1
$\begingroup$

I would never trust playback in blender to be a representation of anything resembling real-time. It really depends on how powerful your computer is. For the most part, preview in the 3d viewport it is usually slower unless you are visualizing on a very simplified mode, like Bunding Box, maybe wireframe and with low settings on modifiers or anything that can help your computer cope with the demands of the scene. If the speed looks fast when you play using frame dropping i probably means that the animation might indeed need to be slowed down. When using Frame Dropping the computer is trying to target the desired frame rate by not generating all of the frames in the animation. To do tests renders use OpenGL rendering (as suggested by @moonboots) It will give you a better sense of what your animation looks like in real-time.

You can of course change the final output's speed by altering the Time-Remapping See: How can I modify the frame rate without changing the overall animation speed?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.