0
$\begingroup$

Made a character and threw it into Mixamo for some basic animations. Trying to edit/add to those animations now before importing into UE4. When I import the fbx to blender, it imports a tpose which is the root position of the armature. No keyframes. I can import the animation into UE4 and see that keyframes do exist and that it is an actual animation, just blender isnt importing properly. Tried in 2.8 and 2.79.

$\endgroup$
1
$\begingroup$

I found that importing the FBX with skin fixes the problem. I hope this helps.

If you export a binary FBX from Blender to Mixamo and get the expected results next thing is to download the FBX with animation and skin. What is usually done is to import all other animations without any skin. There is where I found the problem if The animation is downloaded without skin It wont re-target correctly.

$\endgroup$
  • 3
    $\begingroup$ Can you add a bit more detail, such as a screenshot of your import settings and a bit more explanation of why you think this will work? $\endgroup$ – Sazerac May 14 at 1:15
  • $\begingroup$ Sure, If you export a binary fbx from Blender to Mixamo and get the expected results next thing is to download the FBX with animation and skin. What is usually done is to import all other animations without any skin. There is where I found the problem if The animation is downloaded without skin It wont re target correctly. $\endgroup$ – GameCreatures May 15 at 0:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.