2
$\begingroup$

Any light source in eevee render reflects itself through anything in front of it. The scene in eevee, light passes straight through the reflection.

In cycles, this problem does not exist (obviously) Scene in cycles, problem not present

Enabling contact shadows Kind of fixes it, but it creates a lot of noise and doesn't always work. eevee and contact shadows. Note the inconsistency of the shadows.

Am i missing something? Reflections are done with a plane reflection map,no screen space, everything seems to be in order.

Trying to render the scene properly gives me the same problem. I would like not to provide the scene file, the problem can be easily replicated on default blender 2.8 settings anyway.

I'd like to fix it.

$\endgroup$
  • $\begingroup$ I've just run into this issue. It appears yo;'ve run into a quirk/limitation of the renderer with your sun light source, but I find large lights look pretty horrible on reflective surfaces, regardless. I had to turn the specular to 0 on my main lights to get around it, but this makes the image feel a bit flat. In your scene however it might work without making it look any different. $\endgroup$ – hedgehog90 Apr 28 at 11:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.