5
$\begingroup$

I tried to manipulate a cube with the Boolean modifier. I tried to cut out an edge of the cube with a cylinder. Also, the shading result looks awful in FLAT SHADING mode, so I turned on SMOOTH SHADING.

Has anyone an idea how to achieve a better result. (I also cut out a Sphere first, this made the result less awful).

I used Blender Internal and rendered with smooth shading for smoothness. Using flat shading looks okay, except the "round" cutouts :/ Face normals are okay.

First image is smooth shading. shading problem

EDIT: User Pisurquatre suggested the EdgeSplit modifier, works perfect to me (Maybe a little tweaking here and there): Final Result with EdgeSplit

$\endgroup$
  • $\begingroup$ In the rendered image (with the red arrow) does the cube have smooth shading? I know you said it is flat, but in object mode just hit the flat shading button again. $\endgroup$ – David Jun 27 '14 at 14:02
  • $\begingroup$ Hi David, yeah smooth shading is on. If I use flat shading, the cut out sphere looks really bad (See new image). But Pisurquatre answer worked perfect to me. I edited the Question with the result :) $\endgroup$ – DoubleVoid Jun 27 '14 at 15:34
7
$\begingroup$

That strange line comes from that face being an Ngon. If what you want is for the sharp edges to be flat shaded, and for the smooth parts (cutouts) to be smooth, I suggest to apply smooth shading on the whole object, with an Edge Split modifier. From there you can either mark the sharp edges as sharp, or change the Split Angle setting to fit your needs.

EDIT 2019: This is still the accepted answer, but I recommend looking at Mentalist’s instead.

$\endgroup$
  • 1
    $\begingroup$ Wow thanks, this seems to be the solution :) Thank you very much! I updated my Question with an example render. $\endgroup$ – DoubleVoid Jun 27 '14 at 15:36
  • $\begingroup$ @Pisurquatre But what if you want the edge to be smooth, without the strange line? $\endgroup$ – June Wang May 28 at 19:17
  • $\begingroup$ @JuneWang I don’t know exactly, I could get an acceptable result using Bevel and Weighted Normal (since 2.8) modifiers. Anyway, Mentalist’s answer is better than mine. $\endgroup$ – Pisurquatre May 29 at 9:13
  • $\begingroup$ @Pisurquatre Mentalist's answer works when we want box edge to be sharp. Not sure if there's even a way around this. Tried many approaches already, just couldn't get rid of the Ngons when I bevel the box edge. Thanks anyway. $\endgroup$ – June Wang May 29 at 9:35
  • $\begingroup$ @JuneWang You may have a better chance opening a new, more specific question. $\endgroup$ – Pisurquatre May 29 at 10:30
4
$\begingroup$

Another way is to use the Auto Smooth option in the Mesh Context.

Set your object's shading to Smooth first to see the effect.

Boolean-carved mesh with Auto Smooth enabled

One advantage this has over the Edge Split modifier is that it won't cause problems if you add certain other modifiers subsequently in the stack, such as SubSurf. Another is that it doesn't increase your vertex count.

Note that any edges that have been marked as "sharp" (Edit Mode: CtrlE > Mark Sharp) will remain sharp even when the Auto Smooth angle value is at its maximum 180°. Knowing this, you can manually specify which edges should be sharp instead of relying on an automatic calculation by angle, if you need to be precise.

So you can choose between the Edge Split modifier and Auto Smooth depending on which is most appropriate for your needs.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.