0
$\begingroup$

So I've got this eye texture that is supposed to be transparent, and it was when I was working on a different project, but I decided to restart.

Eye text

So I reloaded everything like the models materials and armature, but the eye texture remained black. I can't figure out how to fix it. waluigi2 waluigi1 waluigi3

$\endgroup$
1
$\begingroup$

The cycles diffuse node does not support transparency on its own. In the material nodes you need to add a transparency node and mix it with the textures alpha channel with a mix node. If you had it transparent from the start it might've been using the blender internal rendering engine which you can change from the top bar where it says cycles render and switching it to blender render.

If you plan on atlasing the textures, using cycles does not support transparency when baking textures.

Setting up the diffusenode to support transparency

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.