2
$\begingroup$

my object with a transparent material and a png texture with alpha channel renders grey instead of transparent.

My setup looks like this (see pictures below) I baked a shadow map and saved the images as an 8-bit RGBA png file to use it as a shadow-map behind my object.

This is my material setup, the final render, where the darker grey plane should not be visible, only the shadow And I already tried to disable shadow rendering for that object. The last image shows, how it should look like

What do I miss here?

correct rendering

This is my material setup

The darker grey plane should not be visible, only the shadow of the closet

Render setup of the shadow plane object

$\endgroup$
2
$\begingroup$

I found the problem. My PNG was not completely transparent where it should be 🤦🏼‍♂️

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.