1
$\begingroup$

Hey so I'm working on a scene with volumetrics enabled in the Eevee render setting (volumetric lightning is on as well).

It shows up in the viewport and it looks fantastic, but as soon as I press F12 to render it out, everything is ok except the volumetrics are not present.

Any idea if it's a bug or I'm doing something wrong somewhere?

Running Blender 2.8 on OSX Mojave (10.14).

$\endgroup$
  • $\begingroup$ Make sure the maximum distance for volumetrics to render is sufficient in the volumetric tab, in Eevee's render settings. $\endgroup$ – Rix Yarbrough Mar 26 at 16:59
  • $\begingroup$ I have the same issue (Blender 2.8rc1) and everything is set correctly AFAICT. Looks great in viewport, renders without volume effects (and same problem in Cycles). $\endgroup$ – podperson Jul 14 at 20:06
  • $\begingroup$ few things to check: 1. are you using transparent background? 2.add sun to scene 3. lower volumetric samples $\endgroup$ – four two Nov 20 at 13:57
0
$\begingroup$

I found a workaround. On your viewport, disable all your overlays and switch to Render View. Click View, then Viewport Render Animation. You can increase your render preview sample equal to the final render too. I did that before when Blender crashed when using conventional render.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.