5
$\begingroup$

I am currently working on the hair for a female character. Two other people worked on the body, and sent me the file from which to make the hair. The body is textured, but the texture file was not packed along with the .blend. (I assumed that wasn't an issue, and went ahead with the hair anyway.)

When I try to unwrap the hair, however, many of the faces get sent to a different UV map for some reason, even though I want the hair to be a cohesive unit. Additionally, the hair is somehow connected to the body (which is a separate object). When I add texture paint to the hair, the body gets painted as well, even though the UV map does not show the body anywhere on it.

enter image description here

There are also some unwanted faces showing up on the hair UV map:

enter image description here

It seems to be attached to the model's stomach for some reason. I need all of the faces of the hair to share the same UV map, and I need the body and hair to be completely separate objects. (The body is actually irrelevant to this project--I'm only working off of it to get the size and shape of the hair correct. The hair itself, so the programmers tell me, will be applied like a wig, so that the character can adopt different hairstyles while keeping the same body model.)

Here's a link to the .blend: http://www.pasteall.org/blend/30038 Thank you in advance for any help!

$\endgroup$
2
$\begingroup$

Both the body and the hair mesh are using the same image (Untitled).

In BI the image displayed on the mesh in textured view is determined by what image is displayed in the UV image editor while that geometry is selected.

Create a new separate image for the hair (AltN in the UV/image editor), then "assign" the hair geometry to that image by selecting it in the image editor with all of the hair geometry selected in edit mode.

Note that this doesn't affect the final render unless you have Face textures enabled.

See How is this blendfile hiding textures? and Texture mapped incorrectly in render?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.