I'll preface this with a few things. This project is being run in Cycles Render. I am a beginner when it comes to using Blender, so please forgive me for obvious errors.

I cannot make my rendered object (a triangle) fully white no matter what I do. Instead, it is gray. I'm not sure what I have enabled that is preventing it from appearing as white instead of gray. Other objects remain white, so I know it isn't so much a scene or lighting issue. I can shift the color as well, but it keeps its gray hue it seems.


Note: Both Viewport Color and Viewport Specular hex values are FFFFFF (whitest, brightest white).

This picture shows the triangle selected. Note that the color on the left indicates it is fully white (in the node as well). enter image description here

The second image here has one of the white bars selected. It has identical an color swatch as the triangle. Why are these bars white yet not the triangle? enter image description here

Each of those bars is its own object, though I understand how it may be misleading.

enter image description here

Does anyone know what I am missing?

  • 2
    $\begingroup$ It looks like you got 2 meshes there. Remove the one without a material. $\endgroup$
    – Mzidare
    Commented Mar 25, 2019 at 18:06
  • $\begingroup$ Sorry, what do you mean? There's another triangle mesh within this triangle? I can move it freely and I find no other object hidden in the same space. $\endgroup$
    – Nightowl
    Commented Mar 25, 2019 at 18:26
  • $\begingroup$ Whoops Mr. Zak, I should have clarified. Each of those bars is its own object, though I understand how it could have been misleading. Here is a picture $\endgroup$
    – Nightowl
    Commented Mar 25, 2019 at 18:57
  • $\begingroup$ @Nightowl can you edit your images to show the material surface values, not the viewport settings? $\endgroup$
    – Sazerac
    Commented Mar 25, 2019 at 23:49
  • 1
    $\begingroup$ It is hard to find then the reason for difference. Note though that Material shading isn't what is going to be rendered and is mainly approximation (though it still should be the same for both materials). If exact values for Material shading are important I think you should attach a copy of the blend file here, use blend-exchange.giantcowfilms.com to do this $\endgroup$
    – Mr Zak
    Commented Mar 26, 2019 at 0:06

1 Answer 1


Update: Looking at your blend, the maximum draw type of your triangle is set to solid, for it to be drawn correctly you need to set it to textured. It can be found under the object tab (orange cube icon).

You need to change the actual material colours to affect the render. These can be found under the surface heading on the materials tab rather than the settings heading, or in the node editor.

enter image description here

The viewport colours you are changing are just that, colours used in the viewport to differentiate between objects, and have no affect on the render.

  • $\begingroup$ Good to know. I can see the preview object (that sphere) change its color, yet I don't know how to make that affect the object in material view in the 3D window. Any changes I make don't seem to do anything with my selected object. $\endgroup$
    – Nightowl
    Commented Mar 27, 2019 at 4:52
  • $\begingroup$ @Nightowl found another issue and updated $\endgroup$
    – Sazerac
    Commented Mar 27, 2019 at 5:07
  • $\begingroup$ Switching to textured resolved my issue! Thank you. As a quick addition before I leave: If I'd like to automate this surface color and have it change live in the 3D view window, should I still automate it from Properties > Material > Surface > Color, or is there a different color picker I should select? I only ask because a quick check of automating this location yields no results. $\endgroup$
    – Nightowl
    Commented Mar 27, 2019 at 6:40
  • $\begingroup$ @Nightowl for simple diffuse only materials that would work, but materials can be much much more complex that that. It is probably worth learning how to use the material node editor. $\endgroup$
    – Sazerac
    Commented Mar 27, 2019 at 6:42
  • $\begingroup$ Will do. Thanks again. $\endgroup$
    – Nightowl
    Commented Mar 27, 2019 at 13:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .